summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-19 02:32:58 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-19 02:44:35 -0500
commit7bb1d0831b096405e49b898c704ecca48f57b1f0 (patch)
treef05a3438fe5a17ee1a3c23c9c629c3198b9a03c1 /sci-calculators/pcalc/pcalc-4.ebuild
parentapp-doc/motif-reference-manual: Bump to EAPI 6. (diff)
downloadgentoo-7bb1d0831b096405e49b898c704ecca48f57b1f0.tar.gz
gentoo-7bb1d0831b096405e49b898c704ecca48f57b1f0.tar.bz2
gentoo-7bb1d0831b096405e49b898c704ecca48f57b1f0.zip
sci-calculators/pcalc: version bump to 4
Diffstat (limited to 'sci-calculators/pcalc/pcalc-4.ebuild')
-rw-r--r--sci-calculators/pcalc/pcalc-4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-calculators/pcalc/pcalc-4.ebuild b/sci-calculators/pcalc/pcalc-4.ebuild
new file mode 100644
index 000000000000..0b083d621208
--- /dev/null
+++ b/sci-calculators/pcalc/pcalc-4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="the programmers calculator"
+HOMEPAGE="https://github.com/vapier/pcalc"
+SRC_URI="mirror://sourceforge/pcalc/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}