summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-06-26 21:20:30 +0200
committerJeroen Roovers <jer@gentoo.org>2018-06-26 21:21:00 +0200
commitfd82bd40312ded4b7de57786920fe72d3a0ae7fa (patch)
treeb45934dd61924a9052cce2625304efb88d469283 /sci-calculators/units/units-2.17.ebuild
parentdev-util/wxglade: Skip tests until we now how to run them (#656934) (diff)
downloadgentoo-fd82bd40312ded4b7de57786920fe72d3a0ae7fa.tar.gz
gentoo-fd82bd40312ded4b7de57786920fe72d3a0ae7fa.tar.bz2
gentoo-fd82bd40312ded4b7de57786920fe72d3a0ae7fa.zip
sci-calculators/units: Version 2.17.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-calculators/units/units-2.17.ebuild')
-rw-r--r--sci-calculators/units/units-2.17.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-calculators/units/units-2.17.ebuild b/sci-calculators/units/units-2.17.ebuild
new file mode 100644
index 000000000000..01fbb74ef39d
--- /dev/null
+++ b/sci-calculators/units/units-2.17.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units_cur? (
+ ${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
+)
+
+pkg_setup() {
+ use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --sharedstatedir="${EROOT}/var/lib" \
+ ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ # we're intentionally delaying this since 'make install' would
+ # get confused if we shove 'units_cur' there, and there is no real
+ # need to add more complexity for it
+ if use units_cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_fix_shebang units_cur
+ python_doscript units_cur
+ fi
+}