summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-10-01 09:22:24 +0200
committerJeroen Roovers <jer@gentoo.org>2020-10-01 10:05:33 +0200
commit164ff1b9911d4fbc62980e2d6bdf65399d1619fa (patch)
tree8b348f66115070296cab4b15e2f8c3f22f7d2744 /sci-calculators/units
parentdev-perl/Config-AutoConf: Bump to version 0.319.0 (diff)
downloadgentoo-164ff1b9911d4fbc62980e2d6bdf65399d1619fa.tar.gz
gentoo-164ff1b9911d4fbc62980e2d6bdf65399d1619fa.tar.bz2
gentoo-164ff1b9911d4fbc62980e2d6bdf65399d1619fa.zip
sci-calculators/units: Version 2.20
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sci-calculators/units')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/files/units-2.20-WIN32.patch24
-rw-r--r--sci-calculators/units/files/units-2.20-readerror.patch11
-rw-r--r--sci-calculators/units/units-2.20.ebuild68
4 files changed, 104 insertions, 0 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index 0265ac770116..ba47bcea8d72 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1,3 +1,4 @@
DIST units-2.16.tar.gz 1178197 BLAKE2B 6de569cd70c8067be053c5acb0885f898b76252bf6bafbea5f8b4972eca0acb13adfb4b2bc70ef0a3df747ee31084076fea3d3199922f0c44fc8c6d08232192b SHA512 afca2bf313208db2d0a3f4e96fed7bb86a3e96030b420e1cfa68a140499b9a8f2ef8c166c1d608d03c9ca6260199569a67c67c623d8c6a4b8d52e9d5cb6e3091
DIST units-2.18.tar.gz 1248892 BLAKE2B b1dd86907ba6af3251577c533d6c39705ff4a8cdf099c15c61efaf7876ee9a4131212e09b3e9ca0f2355fc547256e33be4fcb9efc552b38e3e990e76b9465992 SHA512 2ae9f08acb03f2f443514800dafb454434d7d1a43497d2a937c2e9e8429f63d821be11ae3090693e8cadbd2f9cdeafba8f80c1671d84a9cceb0f72ad75d8cad7
DIST units-2.19.tar.gz 1271288 BLAKE2B b6d61661d88e8221d5689e7f1cdba357479d4e34c4c6fd51c336e76850521b3ad7d8f1bfd9ff8173917931151c8da2180928879be940358e35ae3e96a6e30765 SHA512 f28df8f0b95b53620d4d21ed369551b8510663ff3658293ba62de2722e7dc2d87506db7c65dc192e35f3c3a20842e8ed09ddaa7352532f7e3eaeab4c001061c8
+DIST units-2.20.tar.gz 1309242 BLAKE2B 5321e6234cfe4514d1ebccec490e472ff64a0428bb2721f51e3ff626ddef7eec4b4e8822aa947da1f4ddca414078b617ba34308c86a71788f6d8a9ba20dd6846 SHA512 5292588fb7ea0ab12e45e5521a115a0eaba4e37378011677cbd80e6e17a6ffa5f388a57859c590b6d65460fc91a4ff33e6603e27d4909b8122d4ad3696c8600d
diff --git a/sci-calculators/units/files/units-2.20-WIN32.patch b/sci-calculators/units/files/units-2.20-WIN32.patch
new file mode 100644
index 000000000000..fbe7599831c4
--- /dev/null
+++ b/sci-calculators/units/files/units-2.20-WIN32.patch
@@ -0,0 +1,24 @@
+--- a/units.c
++++ b/units.c
+@@ -4087,7 +4087,9 @@
+ checkcwd (char *file)
+ {
+ FILE *fp;
++#ifdef _WIN32
+ char *p;
++#endif
+
+ fp = fopen(file, "r");
+ if (fp){
+@@ -4630,7 +4630,10 @@
+ printversion()
+ {
+ int exists;
+- char *unitsfile, *localemap;
++ char *unitsfile;
++#ifdef _WIN32
++ char *localemap;
++#endif
+
+ if (flags.verbose == 0) {
+ printf("GNU Units version %s\n", VERSION);
diff --git a/sci-calculators/units/files/units-2.20-readerror.patch b/sci-calculators/units/files/units-2.20-readerror.patch
new file mode 100644
index 000000000000..ccb12c681539
--- /dev/null
+++ b/sci-calculators/units/files/units-2.20-readerror.patch
@@ -0,0 +1,11 @@
+--- a/units.c
++++ b/units.c
+@@ -761,7 +761,7 @@
+ }
+
+
+-#define readerror (goterr=1) && errfile && fprintf
++#define readerror(...) do { goterr=1; if (errfile) fprintf(__VA_ARGS__); } while (0)
+
+ #define VAGUE_ERR "%s: error in units file '%s' line %d\n", \
+ progname, file, linenum
diff --git a/sci-calculators/units/units-2.20.ebuild b/sci-calculators/units/units-2.20.ebuild
new file mode 100644
index 000000000000..2e744c5f60c3
--- /dev/null
+++ b/sci-calculators/units/units-2.20.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units--cur"
+REQUIRED_USE="units--cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units--cur? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
+ "${FILESDIR}"/${PN}-2.20-WIN32.patch
+ "${FILESDIR}"/${PN}-2.20-readerror.patch
+)
+DOCS=(
+ ChangeLog NEWS README
+)
+
+pkg_setup() {
+ use units--cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --sharedstatedir="${EROOT}/var/lib" \
+ ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ default
+
+ # we're intentionally delaying this since 'make install' would
+ # get confused if we shove 'units_cur' there, and there is no real
+ # need to add more complexity for it
+ if use units--cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_fix_shebang units_cur
+ python_doscript units_cur
+ fi
+}