summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/chemtool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/Manifest2
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.13.ebuild57
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.14.ebuild57
-rw-r--r--sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch78
-rw-r--r--sci-chemistry/chemtool/metadata.xml8
5 files changed, 202 insertions, 0 deletions
diff --git a/sci-chemistry/chemtool/Manifest b/sci-chemistry/chemtool/Manifest
new file mode 100644
index 000000000000..a364d0afdaea
--- /dev/null
+++ b/sci-chemistry/chemtool/Manifest
@@ -0,0 +1,2 @@
+DIST chemtool-1.6.13.tar.gz 838868 SHA256 31a07683f55305c3e0c4d7af3bc3d1d3a9a2eff4d836455fe1e382962f0aa0c8 SHA512 6c248321f73b6eab4ad21e810639a1f0b14cc30db9c9fdc8fe66ee218bd88ead5e74f1f047f5badcb91b515827c2eddc64b28ead380d9b14ab5b76777e7134dd WHIRLPOOL c7158a75480e9b98eb2ed5c16d73c4d5e5fa05375009ac1778b7e9bf0e9a2ef9092032557d46ea506a6503c0799676998a6fcb80063ed56a7ae8d360c1f273bc
+DIST chemtool-1.6.14.tar.gz 817735 SHA256 86161a0461386b334a5ffb17cdf094a491941884678272f45749813514ddafcb SHA512 066c83c61aced3134b081767e788143a047889a2fee4b6535c2b0a3166bccc73d75981e1cf35b7bcaa5b8fe2e0227b28693b659decd82f7783cb4082ac6ed2bd WHIRLPOOL 41a2bd4662c06307a94281e6a54d4e129b407bc597c7d08c8a9f976332cb727f3e195d1d85429716ac22a34ea1dae03b724167bbb5444c03dcb24131cc20ae1d
diff --git a/sci-chemistry/chemtool/chemtool-1.6.13.ebuild b/sci-chemistry/chemtool/chemtool-1.6.13.ebuild
new file mode 100644
index 000000000000..2ab2dc197a0b
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.13.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A GTK program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="emf gnome nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/transfig
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ emf? ( media-libs/libemf )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-no-underlinking.patch
+ )
+
+src_configure() {
+ local myeconfargs=(
+ --without-kdedir
+ $(use_with gnome gnomedir /usr)
+ $(use_enable emf)
+ --enable-undo
+ --enable-menu
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /usr/share/${PN}/examples
+ doins "${S}"/examples/*
+ if ! use nls; then rm -rf "${ED}"/usr/share/locale || die; fi
+
+ insinto /usr/share/pixmaps
+ doins chemtool.xpm
+ make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
+}
diff --git a/sci-chemistry/chemtool/chemtool-1.6.14.ebuild b/sci-chemistry/chemtool/chemtool-1.6.14.ebuild
new file mode 100644
index 000000000000..b77cb79569e4
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.14.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
+
+DESCRIPTION="A GTK program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="emf gnome nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/transfig
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ emf? ( media-libs/libemf )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/1.6.13-no-underlinking.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --without-kdedir
+ $(use_with gnome gnomedir /usr)
+ $(use_enable emf)
+ --enable-undo
+ --enable-menu
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /usr/share/${PN}/examples
+ doins "${S}"/examples/*
+ if ! use nls; then rm -rf "${ED}"/usr/share/locale || die; fi
+
+ insinto /usr/share/pixmaps
+ doins chemtool.xpm
+ make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
+}
diff --git a/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch b/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch
new file mode 100644
index 000000000000..5d2fe36d6bf1
--- /dev/null
+++ b/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch
@@ -0,0 +1,78 @@
+ Makefile.am | 6 ++++--
+ configure.ac | 24 ++++--------------------
+ 2 files changed, 8 insertions(+), 22 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 99dbf8c..931ba16 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,10 +22,12 @@ localedir = $(datadir)/locale
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+ # Make sure the gettext.h include file is found.
+-AM_CPPFLAGS = -I. -I$(srcdir) @GTK_CFLAGS@
++AM_CPPFLAGS = -I. -I$(srcdir) @GTK_CFLAGS@ @EMFINCL@
+
+ # Link time dependencies.
+-LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@
++LDADD = @LIBINTL@ @GTK_LIBS@ @EMFLIBS@ -lX11
++
++AM_CFLAGS = -DGTK2
+
+ # Additional files to be distributed.
+ EXTRA_DIST = autogen.sh autoclean.sh
+diff --git a/configure.ac b/configure.ac
+index 6d8c45a..c5fab42 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,32 +32,14 @@ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+
+ AC_MSG_CHECKING([for GTK version and compile options ])
+
+-if test x$PKG_CONFIG = xno -o x$enable_gtk1 = xyes ; then
+-AM_PATH_GTK(1.0.2, , exit 1)
+-else
+-if $PKG_CONFIG gtk+-2.0 --cflags ; then
+- GTK_CFLAGS="-DGTK2 `$PKG_CONFIG gtk+-2.0 --cflags` "
+- GTK_LIBS=`$PKG_CONFIG gtk+-2.0 --libs`
+-dnl use_gtk2=yes
+- AC_DEFINE([GTK2], [1], [the GTK2 library])
+- enable_stockgtk=yes
+-else
+-if $PKG_CONFIG --cflags gtk+ ; then
+- GTK_CFLAGS=`$PKG_CONFIG gtk+ --cflags`
+- GTK_LIBS=`$PKG_CONFIG gtk+ --libs`
+-dnl use_gtk2=no
+-fi
+-fi
+-fi
+-
+-dnl AC_MSG_RESULT using GTK2 : $use_gtk2
++PKG_CHECK_MODULES([GTK],[gtk+-2.0])
+
+ dnl Checks for header files.
+ AC_PATH_XTRA
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+
+-LDFLAGS="$X_LIBS"
++LDFLAGS+="$X_LIBS"
+ AC_CHECK_LIB([X11],[XOpenDisplay])
+ dnl just an ugly hack to work around the more aggressive header checks
+ dnl in recent autoconf. Not sure if we should really rely on include
+@@ -184,6 +166,7 @@ if test x$enable_emf = xyes; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([EMF], [1], [use optional libEMF instead of fig2dev for EMF output])
+ EMFLIBS="-lEMF -lstdc++"
++ EMFINCL="-I${includedir}libEMF"
+ else
+ AC_MSG_RESULT(no)
+ EMFLIBS=""
+@@ -221,6 +204,7 @@ AC_SUBST(localedir)
+ AC_SUBST(kdemimedir)
+ AC_SUBST(gnomemimedir)
+ AC_SUBST(EMFLIBS)
++AC_SUBST(EMFINCL)
+ AC_SUBST(MYGTKSRCS)
+ AC_SUBST(MYGTKOBJS)
+ AC_SUBST(GTK_CFLAGS)
diff --git a/sci-chemistry/chemtool/metadata.xml b/sci-chemistry/chemtool/metadata.xml
new file mode 100644
index 000000000000..26c258873424
--- /dev/null
+++ b/sci-chemistry/chemtool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <use>
+ <flag name="emf">EMF export support</flag>
+ </use>
+</pkgmetadata>