summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-29 14:30:09 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-29 14:30:09 +0200
commitaafe737392a43a92dac2cd87ca068937d9d9df61 (patch)
treeb4ac7deb8bb7414ef4e76e766f9b08a49cf3dacb /sci-chemistry/chemtool
parentsci-chemistry/chemtool: Remove old (diff)
downloadgentoo-aafe737392a43a92dac2cd87ca068937d9d9df61.tar.gz
gentoo-aafe737392a43a92dac2cd87ca068937d9d9df61.tar.bz2
gentoo-aafe737392a43a92dac2cd87ca068937d9d9df61.zip
sci-chemistry/chemtool: Port to EAPI 7
* fix `-fno-common`/GCC 10 * fix broken check target Closes: https://bugs.gentoo.org/708234 Closes: https://bugs.gentoo.org/728954 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry/chemtool')
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.14.ebuild49
-rw-r--r--sci-chemistry/chemtool/files/chemtool-1.6.14-fix-tests.patch6
-rw-r--r--sci-chemistry/chemtool/files/chemtool-1.6.14-fno-common.patch37
-rw-r--r--sci-chemistry/chemtool/files/chemtool-1.6.14-no-underlinking.patch (renamed from sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch)0
4 files changed, 70 insertions, 22 deletions
diff --git a/sci-chemistry/chemtool/chemtool-1.6.14.ebuild b/sci-chemistry/chemtool/chemtool-1.6.14.ebuild
index 58a5d56b105e..3d2d12c9a70c 100644
--- a/sci-chemistry/chemtool/chemtool-1.6.14.ebuild
+++ b/sci-chemistry/chemtool/chemtool-1.6.14.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils eutils
+inherit autotools desktop
DESCRIPTION="A GTK program for drawing organic molecules"
HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
@@ -23,34 +21,41 @@ RDEPEND="
x11-libs/libX11
x11-libs/pango
emf? ( media-libs/libemf )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/1.6.13-no-underlinking.patch
+ "${FILESDIR}"/${P}-no-underlinking.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-fix-tests.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
- --without-kdedir
- $(use_with gnome gnomedir /usr)
+ econf \
+ --enable-undo \
+ --enable-menu \
+ --without-kdedir \
+ $(use_with gnome gnomedir "${EPREFIX}"/usr) \
$(use_enable emf)
- --enable-undo
- --enable-menu
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ default
- insinto /usr/share/${PN}/examples
- doins "${S}"/examples/*
- if ! use nls; then rm -rf "${ED}"/usr/share/locale || die; fi
+ insinto /usr/share/chemtool/examples
+ doins -r examples/.
insinto /usr/share/pixmaps
doins chemtool.xpm
- make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
+
+ if ! use nls; then
+ rm -rf "${ED}"/usr/share/locale || die
+ fi
+
+ make_desktop_entry chemtool Chemtool chemtool "Education;Science;Chemistry"
}
diff --git a/sci-chemistry/chemtool/files/chemtool-1.6.14-fix-tests.patch b/sci-chemistry/chemtool/files/chemtool-1.6.14-fix-tests.patch
new file mode 100644
index 000000000000..755ae3f01914
--- /dev/null
+++ b/sci-chemistry/chemtool/files/chemtool-1.6.14-fix-tests.patch
@@ -0,0 +1,6 @@
+--- /dev/null
++++ b/src-cht/Makefile.am
+@@ -0,0 +1,3 @@
++bin_PROGRAMS = cht
++
++cht_SOURCES = cht.c
diff --git a/sci-chemistry/chemtool/files/chemtool-1.6.14-fno-common.patch b/sci-chemistry/chemtool/files/chemtool-1.6.14-fno-common.patch
new file mode 100644
index 000000000000..d782f8e4a625
--- /dev/null
+++ b/sci-chemistry/chemtool/files/chemtool-1.6.14-fno-common.patch
@@ -0,0 +1,37 @@
+--- a/ct1.h
++++ b/ct1.h
+@@ -273,12 +273,12 @@
+ extern float importfactor;
+ extern int importoffset;
+
+-char **intype;
+-char **inmode;
+-int babelin;
+-char **outtype;
+-char **outmode;
+-int babelout;
++extern char **intype;
++extern char **inmode;
++extern int babelin;
++extern char **outtype;
++extern char **outmode;
++extern int babelout;
+ extern char *babel;
+ extern GdkGC *mygc[8],*background_gc,*hlgc;
+ extern int curpen;
+--- a/inout.c
++++ b/inout.c
+@@ -30,6 +30,13 @@
+ extern GdkFont *font[7],*smallfont[7],*symbfont[7],*boldfont[7],*slfont[7];
+ #endif
+
++char **intype;
++char **inmode;
++int babelin;
++char **outtype;
++char **outmode;
++int babelout;
++
+ static char babeloutp[4];
+
+ int
diff --git a/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch b/sci-chemistry/chemtool/files/chemtool-1.6.14-no-underlinking.patch
index 5d2fe36d6bf1..5d2fe36d6bf1 100644
--- a/sci-chemistry/chemtool/files/1.6.13-no-underlinking.patch
+++ b/sci-chemistry/chemtool/files/chemtool-1.6.14-no-underlinking.patch