summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/cyana
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/cyana')
-rw-r--r--sci-chemistry/cyana/Manifest1
-rw-r--r--sci-chemistry/cyana/cyana-2.1.ebuild72
-rw-r--r--sci-chemistry/cyana/files/2.1-exec.patch77
-rw-r--r--sci-chemistry/cyana/files/2.1-expire.patch15
-rw-r--r--sci-chemistry/cyana/files/2.1-typo.patch13
-rw-r--r--sci-chemistry/cyana/files/2.1-xiar.patch16
-rw-r--r--sci-chemistry/cyana/metadata.xml8
7 files changed, 202 insertions, 0 deletions
diff --git a/sci-chemistry/cyana/Manifest b/sci-chemistry/cyana/Manifest
new file mode 100644
index 000000000000..de99a95f8e55
--- /dev/null
+++ b/sci-chemistry/cyana/Manifest
@@ -0,0 +1 @@
+DIST cyana-2.1.tar.gz 2203650 SHA256 4b49d23eda3a327074fa337c7ee13262e93fb2b92cc6feb9139dfb7695bdeded SHA512 20f5369e47198000927ee9a60beda34d265fddcd6be59f0d5d81ac23691b7e870ca674bdd7215a13bc849586411a007ebb1ff46072b55f255a6d796359067be8 WHIRLPOOL dfc60a456c166d98bbdb60227a2dae63d12ea9fb7375dede3d372a6dbf0785bfd0c8b1069d985a6ee775ab136405b553ff9336a2603d139d81d853f0681f5167
diff --git a/sci-chemistry/cyana/cyana-2.1.ebuild b/sci-chemistry/cyana/cyana-2.1.ebuild
new file mode 100644
index 000000000000..6d042584dbc1
--- /dev/null
+++ b/sci-chemistry/cyana/cyana-2.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Combined assignment and dynamics algorithm for NMR applications"
+HOMEPAGE="http://www.las.jp/english/products/cyana.html"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="CYANA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RESTRICT="fetch"
+
+# we need libg2c for gfortran # 136988
+DEPEND="dev-lang/ifc"
+RDEPEND="${DEPEND}"
+
+pkg_nofetch() {
+ elog "Please visit"
+ elog "http://www.las.jp/english/products/cyana.html"
+ elog "and get a copy of ${A}."
+ elog "Place it in ${DISTDIR}."
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-typo.patch \
+ "${FILESDIR}"/${PV}-exec.patch \
+ "${FILESDIR}"/${PV}-expire.patch \
+ "${FILESDIR}"/${PV}-xiar.patch
+
+ cat >> etc/config <<- EOF
+ VERSION=${PV}
+ SHELL=${EPREFIX}/bin/sh
+ FC=ifort
+ FFLAGS=${FFLAGS} -openmp -threads
+ FFLAGS2=${FFLAGS} -openmp -threads
+ CC=$(tc-getCC)
+ AR=xiar
+ RANLIB=ranlib
+ FORK=g77fork.o
+ LDFLAGS=${LDFLAGS} -reentrancy threaded -openmp
+ LIBS=
+ DEFS=-Dintel
+ SYSTEM=intel
+ EOF
+}
+
+src_compile() {
+ cd src || die
+ emake
+}
+
+src_install() {
+ dobin cyana{job,table,filter,clean}
+ newbin src/${PN}/${PN}exe.* ${PN}
+ insinto /usr/share/${PN}
+ doins -r lib macro help
+ use examples && doins -r demo
+
+ cat >> "${T}"/20cyana <<- EOF
+ CYANALIB="${EPREFIX}/usr/share/${PN}"
+ EOF
+
+ doenvd "${T}"/20cyana
+}
diff --git a/sci-chemistry/cyana/files/2.1-exec.patch b/sci-chemistry/cyana/files/2.1-exec.patch
new file mode 100644
index 000000000000..28cd88d3eee6
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-exec.patch
@@ -0,0 +1,77 @@
+diff --git a/cyana b/cyana
+index 4f746cf..a7ff060 100755
+--- a/cyana
++++ b/cyana
+@@ -45,16 +45,13 @@ shift `expr $optind - 1`
+
+ if [ "$h" ]; then usage=1; fi
+ if [ "$usage" ]; then
+- echo "Usage: $prog -hctx parameters ..."
++ echo "Usage: $prog -hS parameters ..."
+ echo
+ echo " -h help"
+ echo " -c command command to start program (must contain \$exefile)"
+ echo " -S run in safe mode, i.e. within one directory"
+- echo " -t system explicit system type"
+- echo " -x display name of executable without executing it"
+ exit 2
+ fi
+-if [ "$c" ]; then cmd="$c"; fi
+ sys=$t
+ mode=$x
+ safe=$S
+@@ -65,23 +62,6 @@ safe=$S
+ eval ${PROG}ARG='$*'
+ export ${PROG}ARG
+
+-
+-# ------ Set library name ------
+-
+-f=$0
+-if [ `echo $f | sed 's,^/.*,+,'` != "+" ]; then f=`which $0`; fi
+-odir=`pwd`
+-while [ "`ls -l $f | awk '{ print substr($1,1,1) }'`" = "l" ]; do
+- l=`ls -l $f | awk '{ i = NF; print $i }'`
+- cd `dirname $f`; cd `dirname $l`; l=`pwd`/`basename $l`
+- f=$l
+-done
+-cd `dirname $f`
+-libdir=`pwd | sed 's,/src/'${prog}'$,,'`
+-cd $odir
+-eval ${PROG}LIB=$libdir
+-export ${PROG}LIB
+-
+ if [ "$safe" ]; then
+ CYANAINIT=initsafe; export CYANAINIT
+ fi
+@@ -89,29 +69,4 @@ fi
+
+ # ------ Start the program ------
+
+-if [ -d $libdir/src/$prog ]; then
+- exe=$libdir/src/$prog/$exe
+-else
+- exe=$libdir/$exe
+-fi
+-if [ "$sys" = "" ]; then
+- sys=`$libdir/etc/identify`
+- files="$exe.$sys* $exe.gnu $exe.*"
+-else
+- files=$exe.$sys
+-fi
+-for exefile in $files; do
+- if [ -x $exefile ]; then
+- if [ "$mode" ]; then
+- echo $exefile; exit 0
+- else
+- if [ "`echo $cmd | grep -c '\$exefile'`" -gt 0 ]; then
+- eval exec $cmd
+- else
+- eval exec $cmd $exefile
+- fi
+- fi
+- fi
+-done
+-echo "No executable found in \"`dirname $exe`\"."
+-exit 1
++exec cyana
diff --git a/sci-chemistry/cyana/files/2.1-expire.patch b/sci-chemistry/cyana/files/2.1-expire.patch
new file mode 100644
index 000000000000..e18008286f68
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-expire.patch
@@ -0,0 +1,15 @@
+--- src/inclan/unix.for.orig 2011-01-05 14:56:46.572193759 +0100
++++ src/inclan/unix.for 2011-01-05 14:57:27.833627375 +0100
+@@ -206,11 +206,8 @@
+ end if
+ if (iwbeg.lt.0) then
+ iwbeg=igttim
+- iexpir=(julday(12,31,2010)-julday(1,1,1970))*24*3600
+- if (iwbeg.gt.iexpir) call fatmsg ('License expired.')
++ iexpir=iwbeg+100
+ j=(iexpir-iwbeg)/(24*3600)
+- if (j.lt.1000)
+- * call wrnmsg ('License expires in '//plural(j,'day')//'.')
+ end if
+ iwall=igttim-iwbeg
+ c print *,'iwall = ',iwall,iwbeg,idat,itim \ No newline at end of file
diff --git a/sci-chemistry/cyana/files/2.1-typo.patch b/sci-chemistry/cyana/files/2.1-typo.patch
new file mode 100644
index 000000000000..3f011a9b2c28
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-typo.patch
@@ -0,0 +1,13 @@
+diff --git a/src/cyana/putpro.f b/src/cyana/putpro.f
+index d4080f9..4490225 100644
+--- a/src/cyana/putpro.f
++++ b/src/cyana/putpro.f
+@@ -66,7 +66,7 @@ c ------------------------------------------------------ BMRB header
+ * ' _Mol_residue_sequence',
+ * ';'
+ do i=1,nr,20
+- write (iunit,'(20A1))') (rcode(rnam(j)),j=i,min(nr,i+19))
++ write (iunit,'(20A1)') (rcode(rnam(j)),j=i,min(nr,i+19))
+ end do
+
+ write (iunit,'(A)')
diff --git a/sci-chemistry/cyana/files/2.1-xiar.patch b/sci-chemistry/cyana/files/2.1-xiar.patch
new file mode 100644
index 000000000000..e8393253d7f6
--- /dev/null
+++ b/sci-chemistry/cyana/files/2.1-xiar.patch
@@ -0,0 +1,16 @@
+ src/inclan/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/inclan/Makefile b/src/inclan/Makefile
+index fc5a8bf..482d48f 100644
+--- a/src/inclan/Makefile
++++ b/src/inclan/Makefile
+@@ -35,7 +35,7 @@ clean:
+
+ inclan.a: $(OBJS)
+ rm -f $@
+- ar rc $@ $(OBJS)
++ $(AR) rc $@ $(OBJS)
+ if [ "$(RANLIB)" ]; then $(RANLIB) $@; fi
+
+ inclan.o: inclan.for
diff --git a/sci-chemistry/cyana/metadata.xml b/sci-chemistry/cyana/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/cyana/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>