summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-04-17 13:52:39 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-17 22:25:25 +0200
commitb38cce1e33027d963c6f9aac6dfd0376e245024c (patch)
treeba552fce3c590ef5ac4c0ba78d1e14319806fca4 /sci-chemistry/elem/elem-1.0.3-r2.ebuild
parentsci-chemistry/prekin: Port to EAPI 6 (diff)
downloadgentoo-b38cce1e33027d963c6f9aac6dfd0376e245024c.tar.gz
gentoo-b38cce1e33027d963c6f9aac6dfd0376e245024c.tar.bz2
gentoo-b38cce1e33027d963c6f9aac6dfd0376e245024c.zip
sci-chemistry/elem: Port to EAPI 6
Package-Manager: Portage-2.3.29, Repoman-2.3.9
Diffstat (limited to 'sci-chemistry/elem/elem-1.0.3-r2.ebuild')
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r2.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/sci-chemistry/elem/elem-1.0.3-r2.ebuild b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
index 5a9a8c132cf3..daade3396d36 100644
--- a/sci-chemistry/elem/elem-1.0.3-r2.ebuild
+++ b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
@@ -1,34 +1,39 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="periodic table of the elements"
HOMEPAGE="http://elem.sourceforge.net/"
SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~sparc ~x86"
+KEYWORDS="amd64 sparc x86"
SLOT="0"
IUSE=""
DEPEND="x11-libs/xforms"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -e 's:\(^LIBS = .*\):\1 -lXpm:' \
- -e "s:\${FLAGS} -o elem:\$(LDFLAGS) &:" \
- -i Makefile || die #336190
- sed -e "/string.h/ i #include <stdlib.h>" \
- -i elem_cb.c || die #implicit exit()
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-missing-stdlib.patch
+)
+
+src_configure() {
+ tc-export CC
}
src_compile () {
- emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+ emake all
}
src_install () {
- dobin elem elem-de elem-en || die
- dohtml -r doc/* || die
+ dobin elem elem-de elem-en
+
+ rm -rf doc/CVS || die
+ HTML_DOCS=( doc/. )
+ einstalldocs
}