summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-03-07 19:00:08 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-03-07 19:00:26 +0300
commitef5ecf680ba73c80128032ab031589188d49bc50 (patch)
tree802fe77c960f12f348b57e934b7c66089270e84a /sci-chemistry/gmxapi
parentnet-libs/nodejs: Version 11.11.0 (diff)
downloadgentoo-ef5ecf680ba73c80128032ab031589188d49bc50.tar.gz
gentoo-ef5ecf680ba73c80128032ab031589188d49bc50.tar.bz2
gentoo-ef5ecf680ba73c80128032ab031589188d49bc50.zip
sci-chemistry/gmxapi: New package
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry/gmxapi')
-rw-r--r--sci-chemistry/gmxapi/Manifest1
-rw-r--r--sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild60
-rw-r--r--sci-chemistry/gmxapi/metadata.xml12
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-chemistry/gmxapi/Manifest b/sci-chemistry/gmxapi/Manifest
new file mode 100644
index 000000000000..7057d007aed1
--- /dev/null
+++ b/sci-chemistry/gmxapi/Manifest
@@ -0,0 +1 @@
+DIST gmxapi-0.0.7.1.tar.gz 671400 BLAKE2B 5db024bceaed262fc1bd2ef35c0c24a31eff12abde7766ba0eea9d5aabe04c435cdf3c79c04d7932f2110de837a0d06e1f66239f22ba6f313410ed8c9d899788 SHA512 4103d67be3c869907613ec74fc46f14b15242ad93a973fc984dbb25e79bb0bb697d9d2ad9b67a8da2500e5a89b8f78ea1ef1632455af29830e11c2bf1f11bc44
diff --git a/sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild b/sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild
new file mode 100644
index 000000000000..babdf4029762
--- /dev/null
+++ b/sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MAKE_MAKEFILE_GENERATOR="ninja"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="Gromacs API bindings"
+HOMEPAGE="https://github.com/kassonlab/gmxapi"
+SRC_URI="https://github.com/kassonlab/gmxapi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=sci-chemistry/gromacs-2019:="
+RDEPEND="
+ ${DEPEND}
+ sci-libs/scikits[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+src_configure() {
+ my_impl_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_STRIP="${EPREFIX}/bin/true"
+ -DCMAKE_INSTALL_PREFIX="${ED%/}/usr"
+ -DPYTHON_EXECUTABLE="${EPREFIX}/usr/bin/${EPYTHON}"
+ -DGMXAPI_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${EPYTHON}/site-packages/gmx"
+ )
+
+ cmake-utils_src_configure
+ }
+
+ python_foreach_impl my_impl_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_install() {
+ my_impl_src_install() {
+ cd "${BUILD_DIR}" || die
+ cmake-utils_src_install
+ python_optimize
+ }
+
+ python_foreach_impl my_impl_src_install
+}
diff --git a/sci-chemistry/gmxapi/metadata.xml b/sci-chemistry/gmxapi/metadata.xml
new file mode 100644
index 000000000000..7daa2ce7e5f8
--- /dev/null
+++ b/sci-chemistry/gmxapi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+</pkgmetadata>