summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-03-01 17:20:23 +0100
committerPacho Ramos <pacho@gentoo.org>2020-03-01 17:21:16 +0100
commit4a452b0ba33a3764af0d6d378fb7f1606d083ba5 (patch)
tree1927d9a575632ab9534a04279f961a40c5cd8cf0 /sci-chemistry/gnome-chemistry-utils/files
parentdev-util/sysprof: bump to 3.34.1 (diff)
downloadgentoo-4a452b0ba33a3764af0d6d378fb7f1606d083ba5.tar.gz
gentoo-4a452b0ba33a3764af0d6d378fb7f1606d083ba5.tar.bz2
gentoo-4a452b0ba33a3764af0d6d378fb7f1606d083ba5.zip
sci-chemistry/gnome-chemistry-utils: Introduce gnome chemistry utils
Closes: https://bugs.gentoo.org/388887 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry/gnome-chemistry-utils/files')
-rw-r--r--sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch b/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch
new file mode 100644
index 000000000000..826d9b056df8
--- /dev/null
+++ b/sci-chemistry/gnome-chemistry-utils/files/gnome-chemistry-utils-0.14.17-gnumeric.patch
@@ -0,0 +1,47 @@
+Index: gchemutils/configure.ac
+===================================================================
+--- gchemutils/configure.ac (revision 2072)
++++ gchemutils/configure.ac (revision 2073)
+@@ -352,7 +352,7 @@
+ libspreadsheet=libspreadsheet-1.12
+ fi
+
+-PKG_CHECK_MODULES(gnumeric, [$libspreadsheet >= 1.11.6], [build_gnumeric_plugin=yes],
++PKG_CHECK_MODULES(gnumeric, [$libspreadsheet >= 1.12.42], [build_gnumeric_plugin=yes],
+ [build_gnumeric_plugin=no])
+ dnl --without is not handled
+
+Index: gchemutils/gnumeric/functions.cc
+===================================================================
+--- gchemutils/gnumeric/functions.cc (revision 2072)
++++ gchemutils/gnumeric/functions.cc (revision 2073)
+@@ -195,23 +195,23 @@
+ const GnmFuncDescriptor Chemistry_functions[] = {
+
+ { N_("molarmass"), "s",
+- help_molarmass, gnumeric_molarmass, NULL, NULL, NULL,
++ help_molarmass, gnumeric_molarmass, NULL,
+ GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+ { N_("monoisotopicmass"), "s",
+- help_monoisotopicmass, gnumeric_monoisotopicmass, NULL, NULL, NULL,
++ help_monoisotopicmass, gnumeric_monoisotopicmass, NULL,
+ GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+ { N_("chemcomposition"), "ss",
+- help_chemcomposition, gnumeric_chemcomposition, NULL, NULL, NULL,
++ help_chemcomposition, gnumeric_chemcomposition, NULL,
+ GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+ { N_("elementnumber"), "s",
+- help_elementnumber, gnumeric_elementnumber, NULL, NULL, NULL,
++ help_elementnumber, gnumeric_elementnumber, NULL,
+ GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+ { N_("elementsymbol"), "f",
+- help_elementsymbol, gnumeric_elementsymbol, NULL, NULL, NULL,
++ help_elementsymbol, gnumeric_elementsymbol, NULL,
+ GNM_FUNC_SIMPLE, GNM_FUNC_IMPL_STATUS_COMPLETE, GNM_FUNC_TEST_STATUS_NO_TESTSUITE},
+
+
+- {NULL, NULL, NULL, NULL, NULL, NULL, NULL,
++ {NULL, NULL, NULL, NULL, NULL,
+ GNM_FUNC_IS_PLACEHOLDER, GNM_FUNC_IMPL_STATUS_UNIMPLEMENTED, GNM_FUNC_TEST_STATUS_NO_TESTSUITE}
+ };
+