summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2018-10-23 19:42:26 -0600
committerChristoph Junghans <junghans@gentoo.org>2018-10-23 19:42:53 -0600
commit5c3116b436f6c0e23bcfd4459d47bc52c14d0181 (patch)
tree5826460c6c4c0d7082b726e0543dce1ddc63afc6 /sci-chemistry/gromacs
parentdev-ruby/facter: 3.12.1 bump (diff)
downloadgentoo-5c3116b436f6c0e23bcfd4459d47bc52c14d0181.tar.gz
gentoo-5c3116b436f6c0e23bcfd4459d47bc52c14d0181.tar.bz2
gentoo-5c3116b436f6c0e23bcfd4459d47bc52c14d0181.zip
sci-chemistry/gromacs: fix python dep
Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2019.9999.ebuild b/sci-chemistry/gromacs/gromacs-2019.9999.ebuild
index 8a643e0fb30d..2fde5b4b55b7 100644
--- a/sci-chemistry/gromacs/gromacs-2019.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.9999.ebuild
@@ -5,7 +5,9 @@ EAPI=6
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit bash-completion-r1 cmake-utils cuda eutils multilib readme.gentoo-r1 toolchain-funcs xdg-utils
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 cmake-utils cuda eutils multilib python-any-r1 readme.gentoo-r1 toolchain-funcs xdg-utils
if [[ $PV = *9999* ]]; then
EGIT_REPO_URI="git://git.gromacs.org/gromacs.git
@@ -53,7 +55,8 @@ DEPEND="${CDEPEND}
virtual/pkgconfig
doc? (
app-doc/doxygen
- dev-python/sphinx
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
media-gfx/mscgen
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
@@ -165,6 +168,7 @@ src_configure() {
-DGMX_COOL_QUOTES=$(usex offensive)
-DGMX_USE_TNG=$(usex tng)
-DGMX_BUILD_MANUAL=$(usex doc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
-DGMX_HWLOC=$(usex hwloc)
-DGMX_DEFAULT_SUFFIX=off
-DGMX_SIMD="$acce"