summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/molsketch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/molsketch')
-rw-r--r--sci-chemistry/molsketch/Manifest2
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch54
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch16
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch19
-rw-r--r--sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch16
-rw-r--r--sci-chemistry/molsketch/metadata.xml16
-rw-r--r--sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild48
-rw-r--r--sci-chemistry/molsketch/molsketch-0.3.0.ebuild60
8 files changed, 231 insertions, 0 deletions
diff --git a/sci-chemistry/molsketch/Manifest b/sci-chemistry/molsketch/Manifest
new file mode 100644
index 000000000000..28ee7103bdb4
--- /dev/null
+++ b/sci-chemistry/molsketch/Manifest
@@ -0,0 +1,2 @@
+DIST Molsketch-0.2.0-Source.tar.gz 276809 SHA256 05e058bf71fc99e5dda56ef1779a82c8885b2001d1af5dce92d959bf56d8a5d0 SHA512 e72c3b2103d70964ada8bd57cc40c16ae30d0a7c2c45521ca3c7a4c4586270e06707e5d662983a2d0f214b16b12afbfa439b58568873537f70f8ac735aa28d26 WHIRLPOOL 1711ef1e45aa09eda1b6dfa44589b0f235ac533914b343b3802d44faae1f658b668e418014d81a5a797f06132c0c72085eb64b9e8c1f7e22650d4655783cca46
+DIST Molsketch-0.3.0-src.tar.gz 337388 SHA256 078b05bfd591930430bc1e5df802af27bdf40718b9218ba6435eadc209d4d1bc SHA512 405553c9d84f0ce9d70a237834f8273dd5010b95868434f9b1b9042fd626e2782c5d3da7d17d9485946210e48e86d0c2de8385d80667018dbc833c3928d076d4 WHIRLPOOL 659717039bf294072117a8e7dc1cb590c6804d3dbde625aa16451bfdb6371933c71f6241fee1e38cec696bdb89e19111c30cf6ed17810daf09b75272080fbb31
diff --git a/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch b/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch
new file mode 100644
index 000000000000..41ddf01df5f8
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.2.0-openbabel-231.patch
@@ -0,0 +1,54 @@
+ CMakeLists.txt | 12 ++++++------
+ libmolsketch/src/stereocenteritem.cpp | 2 +-
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a4b5d29..f472b40 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,10 +12,10 @@ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
+ # compiler issues are fixed and more warnings are issued. #
+ ###########################################################
+ if (CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror-implicit-function-declaration -Wchar-subscripts")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -fno-common")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror-implicit-function-declaration -Wchar-subscripts")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security")
++# set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-format-attribute -fno-common")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-check-new -fno-common")
+@@ -32,7 +32,7 @@ set(CPACK_SOURCE_IGNORE_FILES "/build;/.git")
+ include(CPack)
+
+ # Unit testing, mainly useful for developers and so defaults to off
+-option(ENABLE_TESTS "Enable unit testing" ON)
++option(ENABLE_TESTS "Enable unit testing" OFF)
+ if(ENABLE_TESTS)
+ set(QT_USE_QTTEST TRUE)
+ enable_testing()
+@@ -48,7 +48,7 @@ configure_file("${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
+ add_custom_target(uninstall "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
+
+ # Enabling debugging symbols
+-set(CMAKE_BUILD_TYPE Debug)
++# set(CMAKE_BUILD_TYPE Debug)
+
+ # Enabling shared libraries
+ set(BUILD_SHARED_LIBS OFF)
+diff --git a/libmolsketch/src/stereocenteritem.cpp b/libmolsketch/src/stereocenteritem.cpp
+index 44a8015..20f2a4a 100644
+--- a/libmolsketch/src/stereocenteritem.cpp
++++ b/libmolsketch/src/stereocenteritem.cpp
+@@ -63,7 +63,7 @@ namespace Molsketch {
+ graphsym.GetSymmetry(symmetry_classes);
+
+ //std::vector<unsigned long> atomIds = FindTetrahedralAtoms(obmol, symmetry_classes);
+- std::vector<OpenBabel::StereogenicUnit> units = FindStereogenicUnits(obmol, symmetry_classes);
++ OpenBabel::OBStereoUnitSet units = FindStereogenicUnits(obmol, symmetry_classes);
+
+ for (unsigned int i = 0; i < units.size(); ++i) {
+ if (units.at(i).type == OpenBabel::OBStereo::Tetrahedral) {
diff --git a/sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch b/sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch
new file mode 100644
index 000000000000..af3b5ceedac6
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.3.0-_DEFAULT_SOURCE.patch
@@ -0,0 +1,16 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e3cd0fe..64c18a2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -19,7 +19,7 @@ if (CMAKE_COMPILER_IS_GNUCXX)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-check-new -fno-common")
+- add_definitions(-D_BSD_SOURCE)
++ add_definitions(-D_DEFAULT_SOURCE)
+ endif (CMAKE_COMPILER_IS_GNUCXX)
+
+ # Enable CPack
diff --git a/sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch b/sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch
new file mode 100644
index 000000000000..fd44e88c7870
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.3.0-desktop.patch
@@ -0,0 +1,19 @@
+ molsketch/src/molsketch.desktop | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/molsketch/src/molsketch.desktop b/molsketch/src/molsketch.desktop
+index a4a5418..4e0a2ef 100644
+--- a/molsketch/src/molsketch.desktop
++++ b/molsketch/src/molsketch.desktop
+@@ -5,9 +5,9 @@ Type=Application
+ Name=molsKetch
+ TryExec=molsketch
+ Exec=molsketch
+-Icon=molsketch.png
++Icon=molsketch
+ DocPath=molsketch/index.html
+-MimeType=chemical/x-cml
++MimeType=chemical/x-cml;
+ Terminal=false
+ Categories=Qt;Education;Science;
+ GenericName=2D molecular structures editor
diff --git a/sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch b/sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch
new file mode 100644
index 000000000000..db7be800e385
--- /dev/null
+++ b/sci-chemistry/molsketch/files/molsketch-0.3.0-no-quotes.patch
@@ -0,0 +1,16 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 64c18a2..75c2fb7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -97,7 +97,7 @@ endif(Qt5Core_FOUND AND Qt5Widgets_FOUND AND Qt5Gui_FOUND AND Qt5PrintSupport_FO
+ if(FORCEQt4)
+ add_definitions(-DQTVERSIONSUFFIX="")
+ else(FORCEQt4)
+- add_definitions(-DQTVERSIONSUFFIX="\\\"-qt5\\\"")
++ add_definitions(-DQTVERSIONSUFFIX="-qt5")
+ endif(FORCEQt4)
+
+ # and OpenBabel2
diff --git a/sci-chemistry/molsketch/metadata.xml b/sci-chemistry/molsketch/metadata.xml
new file mode 100644
index 000000000000..58bc5230b1ab
--- /dev/null
+++ b/sci-chemistry/molsketch/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Molsketch is a 2D molecular editing tool. Its goal is to help you draw
+ molecules quick and easily. Of course you're creation can be exported
+ afterwards in high quality in a number of vector and bitmap formats.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">molsketch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild b/sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..f3184d8d27fd
--- /dev/null
+++ b/sci-chemistry/molsketch/molsketch-0.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+MY_P=${P/m/M}-Source
+
+DESCRIPTION="A drawing tool for 2D molecular structures"
+HOMEPAGE="http://molsketch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ >=sci-chemistry/openbabel-2.2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ >=dev-qt/qthelp-4.7.0:4[compat]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openbabel-231.patch
+ )
+
+src_prepare() {
+ sed -e "/LIBRARY DESTINATION/ s/lib/$(get_libdir)/g" \
+ -i libmolsketch/src/CMakeLists.txt || die #351246
+ sed -e "s:doc/molsketch:doc/${PF}:g" \
+ -i molsketch/src/{CMakeLists.txt,mainwindow.cpp} || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENBABEL2_INCLUDE_DIR="${EPREFIX}/usr/include/openbabel-2.0"
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDE4=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-chemistry/molsketch/molsketch-0.3.0.ebuild b/sci-chemistry/molsketch/molsketch-0.3.0.ebuild
new file mode 100644
index 000000000000..3fec18fd5362
--- /dev/null
+++ b/sci-chemistry/molsketch/molsketch-0.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake-utils multilib qmake-utils
+
+MY_P=${P/m/M}-src
+
+DESCRIPTION="A drawing tool for 2D molecular structures"
+HOMEPAGE="http://molsketch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/Molsketch/Lithium%20${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ >=sci-chemistry/openbabel-2.2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P%%-src}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-no-quotes.patch
+ )
+
+src_prepare() {
+ sed -e "/LIBRARY DESTINATION/ s/lib/$(get_libdir)/g" \
+ -i {obabeliface,libmolsketch/src}/CMakeLists.txt || die #351246
+ sed -e "s:doc/molsketch:doc/${PF}:g" \
+ -i molsketch/src/{CMakeLists.txt,mainwindow.cpp} || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENBABEL2_INCLUDE_DIR="${EPREFIX}/usr/include/openbabel-2.0"
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDE4=ON
+ -DENABLE_TESTS=$(usex test "ON" "OFF")
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dosym ${PN}-qt5 /usr/bin/${PN}
+}