summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/mpqc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/mpqc/files')
-rw-r--r--sci-chemistry/mpqc/files/mpqc-2.3.1-as-needed.patch163
-rw-r--r--sci-chemistry/mpqc/files/mpqc-2.3.1-blas.patch55
-rw-r--r--sci-chemistry/mpqc/files/mpqc-2.3.1-respect-ldflags.patch25
-rw-r--r--sci-chemistry/mpqc/files/mpqc-2.3.1-test-failure-hack.patch11
4 files changed, 254 insertions, 0 deletions
diff --git a/sci-chemistry/mpqc/files/mpqc-2.3.1-as-needed.patch b/sci-chemistry/mpqc/files/mpqc-2.3.1-as-needed.patch
new file mode 100644
index 000000000000..a917c0aaff70
--- /dev/null
+++ b/sci-chemistry/mpqc/files/mpqc-2.3.1-as-needed.patch
@@ -0,0 +1,163 @@
+--- mpqc-2.3.1.orig/src/lib/chemistry/molecule/Makefile 2005-05-26 08:00:29.000000000 +0200
++++ mpqc-2.3.1/src/lib/chemistry/molecule/Makefile 2010-02-13 14:28:46.514285918 +0100
+@@ -66,6 +66,12 @@
+ interface:: $(DEPENDINCLUDE)
+
+ LIBS = $(shell $(LISTLIBS) $(INCLUDE) $(SRCDIR)/LIBS.h)
++LIBADD = $(SRCDIR)/$(TOPDIR)/lib/libSCcontainer.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCclass.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCkeyval.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCoptimize.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCscmat.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCsymmetry.la
+
+ LD = $(CXX)
+
+--- mpqc-2.3.1.orig/src/lib/chemistry/qc/wfn/Makefile 2004-06-12 06:50:35.000000000 +0200
++++ mpqc-2.3.1/src/lib/chemistry/qc/wfn/Makefile 2010-02-13 14:20:06.911896080 +0100
+@@ -48,6 +48,12 @@
+
+ LIBS = $(shell $(LISTLIBS) $(INCLUDE) $(SRCDIR)/../dft/LIBS.h)
+
++LIBADD = $(SRCDIR)/$(TOPDIR)/lib/libSCisosurf.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCsolvent.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCbasis.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCdft.la \
++ $(SRCDIR)/$(TOPDIR)/lib/libSCintv3.la
++
+ wfntest:: wfntest.$(OBJSUF) $(LIBS)
+ $(LTLINK) $(CXX) $(LDFLAGS) -o wfntest $^ $(SYSLIBS) $(LTLINKBINOPTS)
+
+--- mpqc-2.3.1.orig/src/lib/chemistry/qc/intv3/Makefile 2002-04-04 01:08:04.000000000 +0200
++++ mpqc-2.3.1/src/lib/chemistry/qc/intv3/Makefile 2010-02-13 14:04:15.393432311 +0100
+@@ -52,6 +52,8 @@
+ LIBOBJ = $(LIBSRC:%.c=%.$(OBJSUF))
+ LIBOBJ := $(LIBOBJ:%.cc=%.$(OBJSUF))
+
++LIBADD = $(SRCDIR)/$(TOPDIR)/lib/libSCoint3.la
++
+ DISTFILES = $(TESTCSRC) $(INC) atoms.sgen Makefile LIBS.h
+
+ DEPENDINCLUDE = $(INC) $(GENINC) $(SGENINC)
+--- mpqc-2.3.1.orig/src/lib/chemistry/qc/mbpt/Makefile 2005-07-07 17:54:05.000000000 +0200
++++ mpqc-2.3.1/src/lib/chemistry/qc/mbpt/Makefile 2010-02-13 14:12:38.975370147 +0100
+@@ -44,6 +44,7 @@
+ CSRCS = bzerofast.c
+
+ LIBOBJ= $(CXXSRCS:%.cc=%.$(OBJSUF)) $(CSRCS:%.c=%.$(OBJSUF))
++LIBADD= $(SRCDIR)/$(TOPDIR)/lib/libSCsymmetry.la
+
+ default:: $(DEPENDINCLUDE)
+
+--- mpqc-2.3.1.orig/src/lib/chemistry/qc/basis/Makefile 2004-02-11 01:24:43.000000000 +0100
++++ mpqc-2.3.1/src/lib/chemistry/qc/basis/Makefile 2010-02-13 14:04:15.395432868 +0100
+@@ -59,6 +59,7 @@
+ DISTFILES = $(CXXSRC) $(INC) Makefile $(TESTSRC) $(TESTFILES)
+
+ LIBOBJ= $(CXXSRC:%.cc=%.$(OBJSUF))
++LIBADD = $(SYSLIBS)
+
+ default:: $(DEPENDINCLUDE)
+
+--- mpqc-2.3.1.orig/src/lib/math/scmat/Makefile 2003-09-16 17:07:03.000000000 +0200
++++ mpqc-2.3.1/src/lib/math/scmat/Makefile 2010-02-13 14:27:36.028370446 +0100
+@@ -75,6 +75,8 @@
+ DISTFILES = $(CXXSRC) $(INC) scmat.h $(WEBSRC) Makefile LIBS.h \
+ $(TESTSRC) $(TESTFILES)
+
++LIBADD = $(SRCDIR)/$(TOPDIR)/lib/libSCgroup.la $(SYSLIBS)
++
+ LIBS = $(shell $(LISTLIBS) $(INCLUDE) $(SRCDIR)/LIBS.h)
+
+ matrixtest:
+--- mpqc-2.3.1.orig/src/lib/util/class/Makefile 2005-05-26 08:00:49.000000000 +0200
++++ mpqc-2.3.1/src/lib/util/class/Makefile 2010-02-13 14:04:15.396433004 +0100
+@@ -41,6 +41,7 @@
+
+ BIN_OR_LIB = LIB
+ TARGET_TO_MAKE = libSCclass
++LIBADD = $(SYSLIBS)
+
+ TESTCXXSRC = classtest.cc scextest.cc
+ DISTFILES = $(CXXSRC) $(INC) Makefile LIBS.h $(TESTCXXSRC)
+--- mpqc-2.3.1.orig/src/lib/util/state/Makefile 2005-05-26 08:00:51.000000000 +0200
++++ mpqc-2.3.1/src/lib/util/state/Makefile 2010-02-13 14:22:06.302369965 +0100
+@@ -50,6 +50,7 @@
+
+ BIN_OR_LIB = LIB
+ TARGET_TO_MAKE = libSCstate
++LIBADD = $(SRCDIR)/$(TOPDIR)/lib/libSCkeyval.la
+
+ default:: $(DEPENDINCLUDE)
+
+--- mpqc-2.3.1.orig/src/lib/util/group/Makefile 2005-07-30 02:30:18.000000000 +0200
++++ mpqc-2.3.1/src/lib/util/group/Makefile 2010-02-13 14:21:38.582370124 +0100
+@@ -61,6 +61,7 @@
+
+ BIN_OR_LIB = LIB
+ TARGET_TO_MAKE = libSCgroup
++LIBADD = $(SRCDIR)/$(TOPDIR)/lib/libSCkeyval.la
+
+ TESTCXXSRC = pooltest.cc messtest.cc rnglocktest.cc thrtest.cc prttest.cc
+ DISTFILES = $(REQUIREDCXXSRC) $(OPTIONALCXXSRC) $(INC) \
+--- mpqc-2.3.1.orig/src/lib/util/Makefile 2001-08-07 00:29:56.000000000 +0200
++++ mpqc-2.3.1/src/lib/util/Makefile 2010-02-13 14:40:23.611369920 +0100
+@@ -5,7 +5,7 @@
+
+ include $(SRCDIR)/$(TOPDIR)/lib/GlobalMakefile
+
+-SUBDIRS = options ref container class state misc keyval group render
++SUBDIRS = options keyval ref container class state misc group render
+
+ include $(SRCDIR)/$(TOPDIR)/lib/GlobalSubDirs
+
+--- mpqc-2.3.1.orig/lib/GlobalRules 2010-02-13 19:47:19.019432588 +0100
++++ mpqc-2.3.1/lib/GlobalRules 2010-02-13 19:47:57.760370198 +0100
+@@ -75,7 +75,7 @@
+ $(RANLIB) $@
+
+ $(TOPDIR)/lib/$(TARGET_TO_MAKE).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(wildcard $(TMPLREPO)/*.o) $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(wildcard $(TMPLREPO)/*.o) $(LTLINKLIBOPTS) $(LIBADD)
+
+ else
+
+@@ -104,7 +104,7 @@
+ endif
+
+ $(TOPDIR)/lib/$(TARGET_TO_MAKE).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS) $(LIBADD)
+
+ endif
+
+--- mpqc-2.3.1.orig/doc/devsamp/Makefile 2004-04-28 22:45:14.000000000 +0200
++++ mpqc-2.3.1/doc/devsamp/Makefile 2010-02-13 19:58:56.958452043 +0100
+@@ -9,4 +9,4 @@
+ LTLINKBINOPTS := $(shell $(SCCONFIG) --ltlinkbinopts)
+
+ mp2: mp2.o
+- $(LTLINK) $(CXX) $(CXXFLAGS) -o $@ $^ -L$(LIBDIR) -lmpqc $(LIBS) $(LTLINKBINOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $^ -L$(LIBDIR) -lmpqc $(LIBS) $(LTLINKBINOPTS)
+--- mpqc-2.3.1.orig/src/bin/mpqc/Makefile 2005-07-28 18:57:47.000000000 +0200
++++ mpqc-2.3.1/src/bin/mpqc/Makefile 2010-02-13 19:57:40.484216235 +0100
+@@ -82,7 +82,7 @@
+ $(RANLIB) $@
+
+ $(TOPDIR)/lib/libmpqc.la: $(BINOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ install_devel:: $(TOPDIR)/lib/libmpqc.$(LIBSUF)
+ $(INSTALL) $(INSTALLDIROPT) $(installroot)$(libdir)
+--- mpqc-2.3.1.orig/src/lib/chemistry/qc/Makefile.orig 2010-06-18 18:09:58.192621760 +0000
++++ mpqc-2.3.1/src/lib/chemistry/qc/Makefile 2010-06-18 18:10:10.350261767 +0000
+@@ -33,7 +33,7 @@
+ include $(SRCDIR)/$(TOPDIR)/lib/GlobalMakefile
+ include $(TOPDIR)/lib/Makedirlist
+
+-SUBDIRS = basis oint3 intv3 wfn scf dft mbpt
++SUBDIRS = basis oint3 intv3 dft wfn scf mbpt
+ ifeq ($(HAVE_SC_SRC_LIB_CHEMISTRY_QC_PSI),yes)
+ SUBDIRS := $(SUBDIRS) psi
+ endif
diff --git a/sci-chemistry/mpqc/files/mpqc-2.3.1-blas.patch b/sci-chemistry/mpqc/files/mpqc-2.3.1-blas.patch
new file mode 100644
index 000000000000..b99c82fb71da
--- /dev/null
+++ b/sci-chemistry/mpqc/files/mpqc-2.3.1-blas.patch
@@ -0,0 +1,55 @@
+ configure.in | 36 +++---------------------------------
+ 1 files changed, 3 insertions(+), 33 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index ee82977..caae1f9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1487,44 +1487,14 @@ AC_LANG_CPLUSPLUS
+ LIBSSAV="$LIBS"
+ LIBS="$LIBSSAV $FLIBS"
+
+-LIBBLAS=""
+-F77_DGEMM=`$PERL $srcdir/bin/mkf77sym.pl.in -method $F77_SYMBOLS DAXPY`
+-AC_CHECK_FUNC($F77_DGEMM,HAVE_BLAS=yes,[
+- AC_CHECK_LIB(essl,$F77_DGEMM,[HAVE_BLAS=yes;LIBBLAS="-lessl"],
+- AC_CHECK_LIB(blas,$F77_DGEMM,[HAVE_BLAS=yes;LIBBLAS="-lblas"])
+- )]
+-)
+-if test X$HAVE_BLAS != Xyes; then
+- LIBSSAV2="$LIBS"
+- LIBS="-latlas $LIBS"
+- AC_CHECK_LIB(f77blas,$F77_DGEMM,[HAVE_BLAS=yes;LIBBLAS="-lf77blas -latlas"],
+- LIBS="$LIBSSAV2")
+-fi
+-AC_SUBST(HAVE_BLAS)
+-if test X$HAVE_BLAS != Xyes; then
+- echo "WARNING: Could not link to the BLAS library. It can be obtained at"
+- echo "http://www.netlib.org/blas. Use --with-libdirs and/or --with-libs"
+- echo "to specify the name of the library."
+- AC_MSG_ERROR([BLAS is required to complete the build])
+-fi
++PKG_CHECK_MODULES([BLAS], [blas], [LIBBLAS="${BLAS_LIBS}"])
+
+ LIBS="$LIBSSAV $LIBBLAS $FLIBS"
+
+-LIBLAPACK=""
+-F77_DGESVD=`$PERL $srcdir/bin/mkf77sym.pl.in -method $F77_SYMBOLS DGESVD`
+-AC_CHECK_FUNC($F77_DGESVD,HAVE_LAPACK=yes,[
+- AC_CHECK_LIB(lapack,$F77_DGESVD,[HAVE_LAPACK=yes;LIBLAPACK="-llapack"]
+- )]
+-)
+-AC_SUBST(HAVE_LAPACK)
+-if test X$HAVE_LAPACK != Xyes; then
+- echo "Could not link to the LAPACK library. It can be obtained at"
+- echo "http://www.netlib.org/lapack. Use --with-libdirs and/or --with-libs"
+- echo "to specify the name of the library."
+- AC_MSG_ERROR([LAPACK is required to complete the build])
+-fi
++PKG_CHECK_MODULES([LAPACK], [lapack], [LIBLAPACK="${LAPACK_LIBS}"])
+
+ FLIBS="$LIBLAPACK $LIBBLAS $FLIBS"
++
+ AC_LANG_RESTORE
+
+ dnl ----------- check for Scalable BLAS library --------------
diff --git a/sci-chemistry/mpqc/files/mpqc-2.3.1-respect-ldflags.patch b/sci-chemistry/mpqc/files/mpqc-2.3.1-respect-ldflags.patch
new file mode 100644
index 000000000000..c38c9579ddde
--- /dev/null
+++ b/sci-chemistry/mpqc/files/mpqc-2.3.1-respect-ldflags.patch
@@ -0,0 +1,25 @@
+--- mpqc-2.3.1.orig/configure.in 2006-03-22 19:04:54.000000000 +0100
++++ mpqc-2.3.1/configure.in 2010-02-13 17:46:19.545557872 +0100
+@@ -10,6 +10,8 @@
+ AC_CONFIG_HEADER(src/lib/scconfig.h)
+ AC_CONFIG_AUX_DIR(bin)
+
++m4_include([lib/autoconf/cca.m4])
++m4_include([lib/autoconf/acinclude.m4])
+ AC_CANONICAL_SYSTEM
+
+ AC_DEFINE_UNQUOTED(HOST_ARCH, "$host")
+@@ -473,12 +473,10 @@
+ echo Using FORTRAN runtime libraries: $withval
+ )
+
+-LDFLAGS=
+-LIBDIRS=
+ AC_ARG_WITH(libdirs,
+ [ --with-libdirs Specifies library directories (-Ldir1 -Ldir2).],
+ LIBDIRS=$withval
+-LDFLAGS=$withval
++LDFLAGS="$LDFLAGS $withval"
+ echo Using extra library directories: $withval
+ )
+
diff --git a/sci-chemistry/mpqc/files/mpqc-2.3.1-test-failure-hack.patch b/sci-chemistry/mpqc/files/mpqc-2.3.1-test-failure-hack.patch
new file mode 100644
index 000000000000..91fcc30d0d90
--- /dev/null
+++ b/sci-chemistry/mpqc/files/mpqc-2.3.1-test-failure-hack.patch
@@ -0,0 +1,11 @@
+--- mpqc-2.3.1.orig/src/bin/mpqc/validate/Makefile 2006-03-22 19:03:51.000000000 +0100
++++ mpqc-2.3.1/src/bin/mpqc/validate/Makefile 2010-02-13 20:26:12.496370219 +0100
+@@ -52,7 +52,7 @@
+ # Also need to see if --mpqc was specified. If not, then add
+ # --mpqc ../../mpqc.
+ ifeq ($(filter --mpqc%, $(ALL_MPQCRUN_ARGS)),)
+-ALL_MPQCRUN_ARGS:=--mpqc ../../mpqc $(ALL_MPQCRUN_ARGS)
++ALL_MPQCRUN_ARGS:=--mpqc "LD_LIBRARY_PATH=\"../../../../../lib/.libs/\" ../../mpqc" $(ALL_MPQCRUN_ARGS)
+ endif
+
+ ifeq ($(HAVE_SC_SRC_LIB_CHEMISTRY_QC_MBPTR12),yes)