summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-05-19 10:18:08 +0100
committerJustin Lecher <jlec@gentoo.org>2017-05-19 10:52:25 +0100
commitc66f17dceb2a1745d80882ed478f2331735d4a54 (patch)
treea741ef446f80e7b726f40492f40413f25e89c8b0 /sci-chemistry/openbabel
parentdev-python/elasticsearch-py: Restrict test again (diff)
downloadgentoo-c66f17dceb2a1745d80882ed478f2331735d4a54.tar.gz
gentoo-c66f17dceb2a1745d80882ed478f2331735d4a54.tar.bz2
gentoo-c66f17dceb2a1745d80882ed478f2331735d4a54.zip
sci-chemistry/openbabel: Version Bump
which fixes build problems with earlier versions Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=618402 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=618414 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=618542 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/openbabel')
-rw-r--r--sci-chemistry/openbabel/Manifest1
-rw-r--r--sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch4
-rw-r--r--sci-chemistry/openbabel/openbabel-2.4.1.ebuild92
3 files changed, 95 insertions, 2 deletions
diff --git a/sci-chemistry/openbabel/Manifest b/sci-chemistry/openbabel/Manifest
index 082e5b029843..3d09a5c54b9a 100644
--- a/sci-chemistry/openbabel/Manifest
+++ b/sci-chemistry/openbabel/Manifest
@@ -1 +1,2 @@
DIST openbabel-2.3.2.tar.gz 20509105 SHA256 4eaca26679aa6cc85ebf96af19191472ac63ca442c36b0427b369c3a25705188 SHA512 d0e1f8b758ffdd65ec6c31d988bffe3279355e286ce69fad12c5905b3b832e2b73ee95b1061b1576aba1ee9fe4da5e31ec30350c473be17493c657dc80caf919 WHIRLPOOL 74eff18b73d24c8f702e5573a58ba6afba8402e9ce8782de95dc0568575a7d2d632dbc8e8a98b3cd25efdfa7379494f7dcd449342c81ddf73f42a387bce77aaa
+DIST openbabel-2.4.1.tar.gz 11618304 SHA256 204136582cdfe51d792000b20202de8950218d617fd9c6e18cee36706a376dfc SHA512 427e678f0a911bd27b9a8a05e60b6e09f113be4e5dd180daaf80c28d06368e52b57501261755ab3817a8d31f2754db24471fd0ceee706d029386d6f70800e9c6 WHIRLPOOL 88e333b47118449e1edba2b164af77ac7fac9c60e2965b5d6657ba8cf981845f49f6bac9427515ebbdf62668fddf38ae2422c4e107b98df46922c5bba860b216
diff --git a/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch b/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch
index 1354f52685c6..66a796d17b7f 100644
--- a/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch
+++ b/sci-chemistry/openbabel/files/openbabel-2.3.2-test_lib_path.patch
@@ -1,6 +1,6 @@
diff -ru old/openbabel-2.3.0/test/CMakeLists.txt new/openbabel-2.3.0/test/CMakeLists.txt
---- old/openbabel-2.3.0/test/CMakeLists.txt 2010-10-26 17:39:01.000000000 +0300
-+++ new/openbabel-2.3.0/test/CMakeLists.txt 2010-11-14 18:13:32.000000000 +0200
+--- a/test/CMakeLists.txt 2010-10-26 17:39:01.000000000 +0300
++++ b/test/CMakeLists.txt 2010-11-14 18:13:32.000000000 +0200
@@ -2,7 +2,7 @@
add_definitions(-DTESTDATADIR="\\"${CMAKE_SOURCE_DIR}/test/files/\\"")
diff --git a/sci-chemistry/openbabel/openbabel-2.4.1.ebuild b/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
new file mode 100644
index 000000000000..7674873aea95
--- /dev/null
+++ b/sci-chemistry/openbabel/openbabel-2.4.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+
+inherit cmake-utils eutils wxwidgets
+
+DESCRIPTION="Interconverts file formats used in molecular modeling"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
+
+# See src/CMakeLists.txt for LIBRARY_VERSION
+SLOT="0/5.0.0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc openmp test wxwidgets"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/libxml2:2
+ sci-libs/inchi
+ sys-libs/zlib
+ wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS NEWS.md README.md THANKS doc/dioxin.{inc,mol2} doc/README.{dioxin.pov,povray} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.2-gcc-6_and_7-backport.patch
+ )
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+}
+
+src_prepare() {
+ sed \
+ -e '/__GNUC__/s:== 4:>= 4:g' \
+ -i include/openbabel/shared_ptr.h || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ use wxwidgets && need-wxwidgets unicode
+ local mycmakeargs=(
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ -DOPENMP=$(usex openmp)
+ -DBUILD_GUI=$(usex wxwidgets)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ docinto html
+ dodoc doc/{*.html,*.png}
+ if use doc ; then
+ docinto html/API
+ dodoc doc/API/html/*
+ fi
+
+ cmake-utils_src_install
+}
+
+src_test() {
+ local mycmakeargs=(
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ -DPYTHON_EXECUTABLE=false
+ -DOPENMP=$(usex openmp)
+ -DBUILD_GUI=$(usex wxwidgets)
+ -DTESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test -E py
+}
+
+pkg_postinst() {
+ optfeature "perl support" sci-chemistry/openbabel-perl
+ optfeature "python support" sci-chemistry/openbabel-python
+}