summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pdbmat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pdbmat')
-rw-r--r--sci-chemistry/pdbmat/Manifest1
-rw-r--r--sci-chemistry/pdbmat/files/CMakeLists.txt14
-rw-r--r--sci-chemistry/pdbmat/metadata.xml24
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89.ebuild29
4 files changed, 68 insertions, 0 deletions
diff --git a/sci-chemistry/pdbmat/Manifest b/sci-chemistry/pdbmat/Manifest
new file mode 100644
index 000000000000..2a19bccb5f04
--- /dev/null
+++ b/sci-chemistry/pdbmat/Manifest
@@ -0,0 +1 @@
+DIST pdbmat-3.89.tar.gz 124727 SHA256 98f75acd3da3f172213de0688825abad8b3a59c516b5b4ac411a494f6d355f72 SHA512 2c7f8f32344fe1abc662878c2556c10bd6671e683787231827399866f485389c3a63253b00d5a5bdbe8d0b8b779891e846962c9372d927b94c45f0fac59a4fb6 WHIRLPOOL 62f0b8cb2a99797d49c427a085ad24b41e045ba96433cb8c1769c614402cf729737b2335fcb356ad42de1e24079eadccd2c3db6eaa8ff062eb1249a13723b7f0
diff --git a/sci-chemistry/pdbmat/files/CMakeLists.txt b/sci-chemistry/pdbmat/files/CMakeLists.txt
new file mode 100644
index 000000000000..2f1937d84b3f
--- /dev/null
+++ b/sci-chemistry/pdbmat/files/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 2.6)
+project (PDBMAT Fortran)
+
+option (EXAMPLES "Instal additional example files" OFF)
+
+add_executable(diagstd diagstd.f)
+add_executable(pdbmat pdbmat.f)
+
+install (TARGETS diagstd pdbmat DESTINATION bin)
+install (FILES diagstd.README pdbmat.README DESTINATION share/doc/pdbmat)
+
+if ( EXAMPLES )
+ install (DIRECTORY ../Try_ENM2011 DESTINATION share/pdbmat/examples)
+endif (EXAMPLES)
diff --git a/sci-chemistry/pdbmat/metadata.xml b/sci-chemistry/pdbmat/metadata.xml
new file mode 100644
index 000000000000..d542eb59e001
--- /dev/null
+++ b/sci-chemistry/pdbmat/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+A fortran program in which Tirion's model (also called the Elastic Network
+Model) is implemented. Within the frame of this model, atoms (particles)
+less than cutoff (angstroms) away from each others are linked by springs of
+same strength. Alternatively, a list of interacting atoms can be given to the
+program.
+Requirements: a file with the coordinates of the system, in PDB (Protein Data
+Bank) or "x y z mass" format.
+
+Output: the hessian (the mass-weighted second derivatives of energy matrix),
+in the "i j non-zero-ij-matrix-element" format.
+
+Diagstd, a fortran program with a standard diagonalization routine, can next
+be used in order to obtain the corresponding normal modes of the system. If
+the system is large, the RTB approximation can prove usefull (see below).
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
new file mode 100644
index 000000000000..89445471ef73
--- /dev/null
+++ b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Calculate Tirion's model from pdb structures"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+S="${WORKDIR}"/Source_ENM2011
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use examples EXAMPLES)
+ )
+ cmake-utils_src_configure
+}