summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pointless
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pointless')
-rw-r--r--sci-chemistry/pointless/Manifest2
-rw-r--r--sci-chemistry/pointless/files/1.5.1-gcc4.4.patch12
-rw-r--r--sci-chemistry/pointless/metadata.xml8
-rw-r--r--sci-chemistry/pointless/pointless-1.6.14-r1.ebuild56
-rw-r--r--sci-chemistry/pointless/pointless-1.6.14.ebuild60
-rw-r--r--sci-chemistry/pointless/pointless-1.6.2.ebuild60
6 files changed, 198 insertions, 0 deletions
diff --git a/sci-chemistry/pointless/Manifest b/sci-chemistry/pointless/Manifest
new file mode 100644
index 000000000000..63884312ae57
--- /dev/null
+++ b/sci-chemistry/pointless/Manifest
@@ -0,0 +1,2 @@
+DIST pointless-1.6.14.tar.gz 423657 SHA256 68f0c1f65239b1451310fe885c2b9d51fc558de7b43af1e584750e05dc5635d8 SHA512 9dd524a7c842edc01206450c52ca1a01e8e3ee6f9ff71742789943ee10e006b5452b0be3aa509dd16bb85f1b9c3d7954616a78ec2fef2daea7c0ab42cdaa42b9 WHIRLPOOL 5085afbd88713384039ef2c2b4b2f7fddd8f078dca9df54062b0415e970791868c61df98f4044b4e061077a73b4e129b6e5db34852d64cace48108db9c6ae50f
+DIST pointless-1.6.2.tar.gz 412244 SHA256 5e09ca592ea565e8ace142fc0edff39d0ab723f4ac6e2cadd6ba571d667c80f6
diff --git a/sci-chemistry/pointless/files/1.5.1-gcc4.4.patch b/sci-chemistry/pointless/files/1.5.1-gcc4.4.patch
new file mode 100644
index 000000000000..ca67dbd3f336
--- /dev/null
+++ b/sci-chemistry/pointless/files/1.5.1-gcc4.4.patch
@@ -0,0 +1,12 @@
+diff --git a/string_util.hh b/string_util.hh
+index 66af6f3..047512b 100644
+--- a/string_util.hh
++++ b/string_util.hh
+@@ -3,6 +3,7 @@
+
+ #include <string>
+ #include <vector>
++#include <stdio.h>
+ #include "range.hh"
+
+ //======================================================================
diff --git a/sci-chemistry/pointless/metadata.xml b/sci-chemistry/pointless/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/pointless/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/pointless/pointless-1.6.14-r1.ebuild b/sci-chemistry/pointless/pointless-1.6.14-r1.ebuild
new file mode 100644
index 000000000000..d983cb290242
--- /dev/null
+++ b/sci-chemistry/pointless/pointless-1.6.14-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fortran-2 multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Scores crystallographic Laue and space groups"
+HOMEPAGE="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/pointless.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ sci-chemistry/ccp4-apps
+ >=sci-libs/ccp4-libs-6.1.3-r10
+ sci-libs/clipper
+ sci-libs/fftw:2.1
+ sci-libs/mmdb
+ >=sci-libs/cctbx-2010.03.29.2334-r3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.5.1-gcc4.4.patch
+}
+
+src_compile() {
+ emake \
+ -f Makefile.make \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ CLIB="${EPREFIX}/usr/$(get_libdir)" \
+ CCTBX_VERSION=2010 \
+ ICCP4=-I"${EPREFIX}/usr/include/ccp4" \
+ ITBX="-I${EPREFIX}/usr/include" \
+ ICLPR="-I${EPREFIX}/$(python_get_sitedir)/" \
+ LTBX="-L${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/lib -lcctbx" \
+ SLIB="-L${EPREFIX}/usr/$(get_libdir) -lgfortran"
+}
+
+src_install() {
+ dobin pointless othercell
+}
diff --git a/sci-chemistry/pointless/pointless-1.6.14.ebuild b/sci-chemistry/pointless/pointless-1.6.14.ebuild
new file mode 100644
index 000000000000..158bde017aea
--- /dev/null
+++ b/sci-chemistry/pointless/pointless-1.6.14.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils fortran-2 multilib python toolchain-funcs
+
+DESCRIPTION="Scores crystallographic Laue and space groups"
+HOMEPAGE="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/pointless.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ sci-chemistry/ccp4-apps
+ >=sci-libs/ccp4-libs-6.1.3-r10
+ sci-libs/clipper
+ sci-libs/fftw:2.1
+ sci-libs/mmdb
+ >=sci-libs/cctbx-2010.03.29.2334-r3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.5.1-gcc4.4.patch
+}
+
+src_compile() {
+ emake \
+ -f Makefile.make \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ CLIB="${EPREFIX}/usr/$(get_libdir)" \
+ CCTBX_VERSION=2010 \
+ ICCP4=-I"${EPREFIX}/usr/include/ccp4" \
+ ITBX="-I${EPREFIX}/usr/include" \
+ ICLPR="-I${EPREFIX}/$(python_get_sitedir)/" \
+ LTBX="-L${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/lib -lcctbx" \
+ SLIB="-L${EPREFIX}/usr/$(get_libdir) -lgfortran" \
+ || die
+}
+
+src_install() {
+ dobin pointless othercell || die
+}
diff --git a/sci-chemistry/pointless/pointless-1.6.2.ebuild b/sci-chemistry/pointless/pointless-1.6.2.ebuild
new file mode 100644
index 000000000000..2b9f0ad4faa0
--- /dev/null
+++ b/sci-chemistry/pointless/pointless-1.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit eutils fortran-2 multilib python toolchain-funcs
+
+DESCRIPTION="Scores crystallographic Laue and space groups"
+HOMEPAGE="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/pointless.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ sci-chemistry/ccp4-apps
+ >=sci-libs/ccp4-libs-6.1.3-r10
+ sci-libs/clipper
+ sci-libs/fftw:2.1
+ sci-libs/mmdb
+ >=sci-libs/cctbx-2010.03.29.2334-r3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ python_pkg_setup
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.5.1-gcc4.4.patch
+}
+
+src_compile() {
+ emake \
+ -f Makefile.make \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ CLIB="${EPREFIX}/usr/$(get_libdir)" \
+ CCTBX_VERSION=2010 \
+ ICCP4=-I"${EPREFIX}/usr/include/ccp4" \
+ ITBX="-I${EPREFIX}/usr/include" \
+ ICLPR="-I${EPREFIX}/$(python_get_sitedir)/" \
+ LTBX="-L${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/lib -lcctbx" \
+ SLIB="-L${EPREFIX}/usr/$(get_libdir) -lgfortran"
+}
+
+src_install() {
+ dobin pointless othercell
+}