summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2017-03-27 17:08:53 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2017-03-27 17:09:21 +0300
commitf7f304a16a0f4530e49dc100bc4a542b457a5e28 (patch)
treee6dcc790478d073ac20adc0b00c03352e5a0db42 /sci-chemistry/pymol
parentdev-libs/libgcrypt: prune la files properly (diff)
downloadgentoo-f7f304a16a0f4530e49dc100bc4a542b457a5e28.tar.gz
gentoo-f7f304a16a0f4530e49dc100bc4a542b457a5e28.tar.bz2
gentoo-f7f304a16a0f4530e49dc100bc4a542b457a5e28.zip
sci-chemistry/pymol: Version bump
Warning: Pymol now depends on dev-libs/msgpack Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/Manifest1
-rw-r--r--sci-chemistry/pymol/pymol-1.8.6.0.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 1f72685ea0c8..b4695e66d6de 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,2 +1,3 @@
DIST pymol-1.8.4.0.png.xz 19528 SHA256 e2c956b39965130a3dc51c2c1b1090bee6bf591885069b2ddb77c0991e9e4928 SHA512 40bb0d3f226476f6e047b5361956aad955232a97641474765eaa5204f0539aee3810e0266213618a45364f9f31f6eb18380b17e0c79f64065f7b62a9016caa7c WHIRLPOOL 1336c20e068b71cdf35118c84b5df8485c86bc51eed7f542a483fb78ce374ca76e4aed3518aced0a6f8ea49e0b180004e567cc059ac52a27a3d616adb282cea2
DIST pymol-v1.8.4.0.tar.bz2 8717344 SHA256 b6147befe74844dd23550461b831b2fa6d170d4456f0059cf93fb1e8cb43d279 SHA512 73a810adfc31adaf0f3fa25512084882c87b0782c8af716ac0203a5b5b7f0b9fedfbce3d129bffef7b52044e92b0542e683966b2acf961c4dac17fbba72dd7fe WHIRLPOOL 3943a619ca00cc2bfb51ff4dffa0166856b4425c7518d91b1ff2a048caa53dcb7411c64b246014b860b7f036de582e9efdc09783b3918283f0a96ee5130c7287
+DIST pymol-v1.8.6.0.tar.bz2 8717164 SHA256 7eaaf90ac1e1be0969291cdb1154b3631b5b6403cce1d697133d90cd37a3c565 SHA512 bd08e6890382af1503d6af16b27b43af09b372a1229cc9d8e2de311873918b5e7b06e8a2365ce73a5f52cb31ac795f5d91b2ae6ef62890d9c2bf0ea25f856658 WHIRLPOOL 950d655a48b3801de2657b6d8935404ca0069525719b9c88a117ad819c37366a55e42dbe51a253b960b79413e5df9d781b9ada8839ca06e1e01dde965044efe4
diff --git a/sci-chemistry/pymol/pymol-1.8.6.0.ebuild b/sci-chemistry/pymol/pymol-1.8.6.0.ebuild
new file mode 100644
index 000000000000..8fd0a78a12a1
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.8.6.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 eutils fdo-mime flag-o-matic versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ https://dev.gentoo.org/~jlec/distfiles/${PN}-1.8.4.0.png.xz
+ mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV}.tar.bz2
+ "
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+RESTRICT="mirror"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="web"
+
+DEPEND="
+ dev-libs/msgpack[cxx]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freeglut
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/python-pmw[${PYTHON_USEDEP}]
+ !sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+
+ append-cxxflags -std=c++0x
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install --pymol-path="${EPREFIX}/usr/share/pymol"
+
+ sed \
+ -e '1d' \
+ -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
+ -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ sed \
+ -e '1i#!/usr/bin/env python' \
+ "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
+
+ python_foreach_impl python_doscript "${T}"/${PN}
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/usr/share/pymol"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.8.4.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ optfeature "Electrostatic calculations" sci-chemistry/apbs sci-chemistry/pdb2pqr
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}