summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 17:36:24 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 17:36:35 +0100
commit0976e9cfcde80f655c375a8499124a979df97332 (patch)
tree123229e99bc19ed2eb36478b5b17803fee364032 /sci-chemistry/relax
parentdev-scheme/gauche: fix build on ia64 (diff)
downloadgentoo-0976e9cfcde80f655c375a8499124a979df97332.tar.gz
gentoo-0976e9cfcde80f655c375a8499124a979df97332.tar.bz2
gentoo-0976e9cfcde80f655c375a8499124a979df97332.zip
sci-chemistry/relax: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'sci-chemistry/relax')
-rw-r--r--sci-chemistry/relax/relax-4.0.0-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sci-chemistry/relax/relax-4.0.0-r1.ebuild b/sci-chemistry/relax/relax-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..b5950de01228
--- /dev/null
+++ b/sci-chemistry/relax/relax-4.0.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="3.0"
+
+inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/Numdifftools[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ media-gfx/pngcrush
+ test? ( ${RDEPEND} )
+ "
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib extern/numdifftools || die
+ tc-export CC
+ need-wxwidgets unicode
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
+ virtualmake
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}