summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/theseus/theseus-3.3.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/theseus/theseus-3.3.0.ebuild')
-rw-r--r--sci-chemistry/theseus/theseus-3.3.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-chemistry/theseus/theseus-3.3.0.ebuild b/sci-chemistry/theseus/theseus-3.3.0.ebuild
new file mode 100644
index 000000000000..ed80be95d26b
--- /dev/null
+++ b/sci-chemistry/theseus/theseus-3.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Maximum likelihood superpositioning and analysis of macromolecular structures"
+HOMEPAGE="http://www.theseus3d.org/"
+SRC_URI="http://www.theseus3d.org/src/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-libs/gsl
+ || (
+ sci-biology/muscle
+ sci-biology/probcons
+ sci-biology/mafft
+ sci-biology/t-coffee
+ sci-biology/kalign
+ sci-biology/clustalw:2
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}_src/
+
+src_prepare() {
+ cat >> make.inc <<- EOF
+ ARCH = $(tc-getAR)
+ ARCHFLAGS = -rvs
+ RANLIB = $(tc-getRANLIB)
+ LOCALLIBDIR = "${EPREFIX}/usr/$(get_libdir)
+ SYSLIBS = $(pkg-config --libs gsl) -lpthread
+ LIBS = -ldistfit -lmsa -ldssplite -ldltmath -lDLTutils -ltheseus
+ LIBDIR = -L./lib
+ INSTALLDIR = "${ED}"/usr/bin
+ OPT =
+ WARN =
+ CFLAGS = ${CFLAGS} -std=c11 \$(WARN)
+ CC = $(tc-getCC)
+ EOF
+
+ sed \
+ -e 's|theseus:|theseus: libs|g' \
+ -e '/-o theseus/s:$(CC):$(CC) ${LDFLAGS}:g' \
+ -i Makefile || die
+
+ sed \
+ -e 's:/usr/bin/sed:sed:g' \
+ -e "s:/usr/local/bin/:/usr/bin/:g" \
+ -e "s:/usr/bin/:${EPREFIX}/usr/bin/:g" \
+ -i theseus_align || die
+}
+
+src_compile () {
+ emake ltheseus
+ default
+}
+
+src_install() {
+ dobin theseus theseus_align
+ dodoc theseus_man.pdf README AUTHORS
+ use examples && insinto /usr/share/${PN} && doins -r examples
+}