summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/tinker/tinker-7.1.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/tinker/tinker-7.1.2.ebuild')
-rw-r--r--sci-chemistry/tinker/tinker-7.1.2.ebuild104
1 files changed, 104 insertions, 0 deletions
diff --git a/sci-chemistry/tinker/tinker-7.1.2.ebuild b/sci-chemistry/tinker/tinker-7.1.2.ebuild
new file mode 100644
index 000000000000..e81b4a6b6a1d
--- /dev/null
+++ b/sci-chemistry/tinker/tinker-7.1.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic fortran-2 java-pkg-opt-2 toolchain-funcs
+
+DESCRIPTION="Molecular modeling package that includes force fields, such as AMBER and CHARMM"
+HOMEPAGE="http://dasher.wustl.edu/tinker/"
+SRC_URI="http://dasher.wustl.edu/${PN}/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Tinker"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="
+ >=virtual/jdk-1.6"
+RDEPEND="
+ >=sci-libs/fftw-3.2.2-r1[fortran,threads]
+ dev-libs/maloc
+ !dev-util/diffuse
+ >=virtual/jre-1.6"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"/${PN}/source
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
+ tc-has-openmp || die "Please use an openmp capable compiler like gcc[openmp]"
+}
+
+src_prepare() {
+ sed 's:strip:true:g' -i ../make/Makefile
+ [[ $(tc-getFC) =~ "ifort" ]] || epatch "${FILESDIR}"/${PV}-openmp.patch
+ cd .. && epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ local javalib=
+ for i in $(java-config -g LDPATH | sed 's|:| |g'); do
+ [[ -f ${i}/libjvm.so ]] && javalib=${i}
+ done
+
+ # use dummy routines in pmpb.f instead of apbs calls
+ rm pmpb.c || die
+
+ if [[ $(tc-getFC) =~ "gfortran" ]]; then
+ append-flags -fopenmp
+ _omplib="-lgomp"
+ else
+ append-flags -openmp
+ _omplib="-liomp5"
+ fi
+
+ _fftwlib="$($(tc-getPKG_CONFIG) --libs fftw3 fftw3_threads)"
+
+ emake \
+ -f ../make/Makefile \
+ F77="$(tc-getFC)" \
+ CC="$(tc-getCC) -c" \
+ F77FLAGS=-c \
+ OPTFLAGS="${FFLAGS}" \
+ LINKFLAGS="${LDFLAGS} -Wl,-rpath ${javalib}" \
+ INCLUDEDIR="$(java-pkg_get-jni-cflags) -I${EPREFIX}/usr/include" \
+ LIBS="-lmaloc -L${javalib} -ljvm ${_omplib} ${_fftwlib}" \
+ all
+
+ mkdir "${S}"/../bin || die
+
+ emake \
+ -f ../make/Makefile \
+ BINDIR="${S}"/../bin \
+ rename
+}
+
+src_test() {
+ cd "${WORKDIR}"/${PN}/test/
+ for test in *.run; do
+ einfo "Testing ${test} ..."
+ bash ${test} || die
+ done
+}
+
+src_install() {
+ dobin "${WORKDIR}"/${PN}/perl/mdavg "${WORKDIR}"/${PN}/bin/*
+
+ insinto /usr/share/${PN}/
+ doins -r "${WORKDIR}"/${PN}/params
+
+ dodoc \
+ "${WORKDIR}"/${PN}/doc/{*.txt,*.pdf,0README}
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r "${WORKDIR}"/${PN}/example
+
+ doins -r "${WORKDIR}"/${PN}/test
+ fi
+
+}