summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2020-06-21 09:06:49 -0600
committerChristoph Junghans <junghans@gentoo.org>2020-06-21 09:41:38 -0600
commit722000e753be63f97c024bdf42c65ccb9ecf91c6 (patch)
tree364b6be8c84295b5b2b127a583fbf804f7c12a51 /sci-chemistry/votca-csgapps/votca-csgapps-1.6.1.ebuild
parentsci-chemistry/votca-csg: version bump (diff)
downloadgentoo-722000e753be63f97c024bdf42c65ccb9ecf91c6.tar.gz
gentoo-722000e753be63f97c024bdf42c65ccb9ecf91c6.tar.bz2
gentoo-722000e753be63f97c024bdf42c65ccb9ecf91c6.zip
sci-chemistry/votca-csgapps: version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.6.1.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.6.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.6.1.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.6.1.ebuild
new file mode 100644
index 000000000000..cc4f98d6f30b
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )