summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/xdsstat-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/xdsstat-bin')
-rw-r--r--sci-chemistry/xdsstat-bin/Manifest2
-rw-r--r--sci-chemistry/xdsstat-bin/metadata.xml8
-rw-r--r--sci-chemistry/xdsstat-bin/xdsstat-bin-140225.ebuild33
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/xdsstat-bin/Manifest b/sci-chemistry/xdsstat-bin/Manifest
new file mode 100644
index 000000000000..4ce0a18a1d13
--- /dev/null
+++ b/sci-chemistry/xdsstat-bin/Manifest
@@ -0,0 +1,2 @@
+DIST xdsstat-linux32.bz2 235255 SHA256 366b9565a172b9ab756e1669a353003c74b9e0341bba5b1822fef775a35e1290 SHA512 233c25b60501f794887a09960e2e8377c0443bce661c769624d8afcde288b58968b3406cc7e1bb02f0de010f4e6555ef0641fd5ebcfdd5f6396ec21a22c32985 WHIRLPOOL a304fd23eaf3d8292f3bc414e6bc1c1b5895590b4235e637d357a4a462c91939195fd99764b4233775f1dd6d65601391d4c6328fe578734dae498e6f382e96f7
+DIST xdsstat-linux64.bz2 256555 SHA256 45408d09cb13ec664e863863ec66a1cece204308e074f29f54f922d804f042f9 SHA512 d5b3043bec30a17f6960308d642a3721f7a73bc851a71ec28a813b5a98f2de4f215d3603e8da4a9bcb949cfa15030c3eac108bc5549ebdef6737885e60dbd626 WHIRLPOOL 5d81ba5998e6c527978f10e0aa2ded7c8ada53beb6340ba592d74b34a64a81e17c0184d101dc7698d4771458d0e27559fb857fd329be8eb95a4f75136f549790
diff --git a/sci-chemistry/xdsstat-bin/metadata.xml b/sci-chemistry/xdsstat-bin/metadata.xml
new file mode 100644
index 000000000000..ae9ec7c5f6a4
--- /dev/null
+++ b/sci-chemistry/xdsstat-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/xdsstat-bin/xdsstat-bin-140225.ebuild b/sci-chemistry/xdsstat-bin/xdsstat-bin-140225.ebuild
new file mode 100644
index 000000000000..7bed425330c3
--- /dev/null
+++ b/sci-chemistry/xdsstat-bin/xdsstat-bin-140225.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Prints various statistics (that are not available from XDS itself)"
+HOMEPAGE="http://strucbio.biologie.uni-konstanz.de/xdswiki/index.php/XDSSTAT"
+SRC_URI="
+ amd64? ( ftp://turn5.biologie.uni-konstanz.de/pub/${MY_PN}-linux64.bz2 )
+ x86? ( ftp://turn5.biologie.uni-konstanz.de/pub/${MY_PN}-linux32.bz2 )
+"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-chemistry/xds-bin"
+DEPEND=""
+
+RESTRICT="mirror"
+
+QA_PREBUILT="opt/bin/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /opt/bin
+ newexe ${MY_PN}* ${MY_PN}
+}