summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/xia2/xia2-0.3.3.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/xia2/xia2-0.3.3.3.ebuild')
-rw-r--r--sci-chemistry/xia2/xia2-0.3.3.3.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-chemistry/xia2/xia2-0.3.3.3.ebuild b/sci-chemistry/xia2/xia2-0.3.3.3.ebuild
new file mode 100644
index 000000000000..60778aa75fb9
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="http://www.ccp4.ac.uk/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=sci-chemistry/ccp4-apps-6.1.2
+ sci-chemistry/mosflm
+ sci-chemistry/pointless
+ >=sci-libs/ccp4-libs-6.1.2
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ find . -name '*.bat' -delete || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_install() {
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${ED}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME="${EPREFIX}/usr/share/ccp4/XIAROOT"
+ XIA2CORE_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2core-${PV}"
+ XIA2_ROOT="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}"
+ PATH="${EPREFIX}/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications"
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+ echo ""
+ elog "In order to use the package, you need to"
+ elog "\t source ${EPREFIX}/etc/profile"
+ echo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}