summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2020-07-01 01:29:39 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2020-07-01 01:43:36 +0300
commit35c53b263ca449cfa6602fc548d89f839eaae5ee (patch)
treed8e3bead1737784e46f42da5e0ba2217f5140648 /sci-chemistry
parentmedia-libs/mesa: Version bump to 20.1.2 (diff)
downloadgentoo-35c53b263ca449cfa6602fc548d89f839eaae5ee.tar.gz
gentoo-35c53b263ca449cfa6602fc548d89f839eaae5ee.tar.bz2
gentoo-35c53b263ca449cfa6602fc548d89f839eaae5ee.zip
sci-chemistry/propka: Version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/propka/Manifest2
-rw-r--r--sci-chemistry/propka/metadata.xml12
-rw-r--r--sci-chemistry/propka/propka-3.2.0.ebuild (renamed from sci-chemistry/propka/propka-3.1_p140511.ebuild)23
3 files changed, 22 insertions, 15 deletions
diff --git a/sci-chemistry/propka/Manifest b/sci-chemistry/propka/Manifest
index 7e3748e1a98b..4141de909047 100644
--- a/sci-chemistry/propka/Manifest
+++ b/sci-chemistry/propka/Manifest
@@ -1 +1 @@
-DIST propka-3.1_p140511.tar.xz 151284 BLAKE2B 16b3528fb9ac224632f99c665c98b2349e49af92479a0b1ec411a08196724c14ba35199c69280d9f1c7e6126a347eede70e229ebd76392d887fe8bef7aad9283 SHA512 c2938af41ed386e267cd045b14e34779889b3c206016d747b68c400f2c8b37bd50cc3b74d055d931476065ac6817a2dd2cb87d68de9911adfff1c8e34a667fc3
+DIST propka-3.2.0.tar.gz 73746 BLAKE2B f79e493d5a195b81dc5d11cc21b9ab16c8d1fa48f15f7e23e2b2936dfb8634fdb00c7838b8dbdb4a68726dab0f16e54522ad71d71b3273ac93c03a737ae06f04 SHA512 98f2240b28b33bab94cdbe9392062bb7f6b87e75b94c2af91e178f874a74d210601161ebc835c4d751b89d37b32348fdfb096e28cbf8e9237b3f472d3fb6b4fc
diff --git a/sci-chemistry/propka/metadata.xml b/sci-chemistry/propka/metadata.xml
index 8937bad0b175..6bfad85b4001 100644
--- a/sci-chemistry/propka/metadata.xml
+++ b/sci-chemistry/propka/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">propka</remote-id>
+ <remote-id type="github">jensengroup/propka</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-chemistry/propka/propka-3.1_p140511.ebuild b/sci-chemistry/propka/propka-3.2.0.ebuild
index 4b90e9aeab97..b5dadd1825d2 100644
--- a/sci-chemistry/propka/propka-3.1_p140511.ebuild
+++ b/sci-chemistry/propka/propka-3.2.0.ebuild
@@ -1,24 +1,28 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
DESCRIPTION="pKa-value prediction of ionizable groups in protein and protein-ligand complexes"
-HOMEPAGE="http://propka.ki.ku.dk/"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+HOMEPAGE="https://github.com/jensengroup/propka"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
-LICENSE="all-rights-reserved"
+LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RESTRICT="!test? ( test )"
-RESTRICT="mirror bindist"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ ${RDEPEND}
+ dev-python/pandas[${PYTHON_USEDEP}]
+)"
python_prepare_all() {
sed -e "/exclude/s:scripts:\', \'Tests:g" \
@@ -32,6 +36,5 @@ python_test() {
}
python_install_all() {
- dosym ${PN}31 /usr/bin/${PN}
distutils-r1_python_install_all
}