summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-02 13:48:56 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-02 14:00:44 +0200
commit86a55f2707b1daa78e8d7e0666756e95ef588d47 (patch)
treec9d06a1cd62ed1d360a74af2f0045e69cab0a6c4 /sci-chemistry
parentsci-chemistry/dssp: Bump to 4.0.1 (diff)
downloadgentoo-86a55f2707b1daa78e8d7e0666756e95ef588d47.tar.gz
gentoo-86a55f2707b1daa78e8d7e0666756e95ef588d47.tar.bz2
gentoo-86a55f2707b1daa78e8d7e0666756e95ef588d47.zip
sci-chemistry/dssp: Fix boost compat for dssp-2
dssp-2 is still needed by gromacs, try to keep it whenever possible then Closes: https://bugs.gentoo.org/802417 Closes: https://bugs.gentoo.org/808669 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/dssp/dssp-2.2.1-r3.ebuild41
-rw-r--r--sci-chemistry/dssp/files/30-dssp1
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/dssp-2.2.1-r3.ebuild b/sci-chemistry/dssp/dssp-2.2.1-r3.ebuild
new file mode 100644
index 000000000000..17a89bb51ffc
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-2.2.1-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/"
+SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dssp-2/${P}.tgz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads(+)]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-gentoo.patch
+ "${FILESDIR}"/${PN}-2.2.1-boost-1.65-tr1-removal.patch
+)
+
+src_configure() {
+ tc-export CXX
+
+ cat >> make.config <<- EOF || die
+ BOOST_LIB_DIR = "${EPREFIX}/usr/$(get_libdir)"
+ BOOST_INC_DIR = "${EPREFIX}/usr/include"
+ EOF
+}
+
+src_install() {
+ dobin mkdssp
+ dosym mkdssp /usr/bin/dssp
+ doman doc/mkdssp.1
+ dodoc README.txt changelog
+
+ doenvd "${FILESDIR}"/30-${PN}
+}
diff --git a/sci-chemistry/dssp/files/30-dssp b/sci-chemistry/dssp/files/30-dssp
new file mode 100644
index 000000000000..e0a5e0ce5626
--- /dev/null
+++ b/sci-chemistry/dssp/files/30-dssp
@@ -0,0 +1 @@
+DSSP=/usr/bin/dssp \ No newline at end of file