summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-11 15:10:12 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-11 16:09:16 +0100
commit877582dae6848c1ba8a82b7437ba8a604b56ed18 (patch)
treed5560073b634fea0765476677360ca2a5dfd014f /sci-chemistry
parentsci-chemistry/pymol: x86 stable wrt bug #565494 (diff)
downloadgentoo-877582dae6848c1ba8a82b7437ba8a604b56ed18.tar.gz
gentoo-877582dae6848c1ba8a82b7437ba8a604b56ed18.tar.bz2
gentoo-877582dae6848c1ba8a82b7437ba8a604b56ed18.zip
sci-chemistry/openbabel-python: Adopt to ABIFLAGS change in python
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
index 114ace5e00a0..94b84d56e59a 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
@@ -57,12 +57,12 @@ src_configure() {
-DBINDINGS_ONLY=ON
-DBABEL_SYSTEM_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libopenbabel.so"
-DOB_MODULE_PATH="${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}"
- -DLIB_INSTALL_DIR="${ED}/usr/$(get_libdir)/${EPYTHON}/site-packages"
+ -DLIB_INSTALL_DIR="${D}$(python_get_sitedir)"
-DPYTHON_BINDINGS=ON
-DPYTHON_EXECUTABLE=${PYTHON}
- -DPYTHON_INCLUDE_DIR="${EPREFIX}/usr/include/${EPYTHON}"
- -DPYTHON_INCLUDE_PATH="${EPREFIX}/usr/include/${EPYTHON}"
- -DPYTHON_LIBRARY="${EPREFIX}/usr/$(get_libdir)/lib${EPYTHON}.so"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_INCLUDE_PATH="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
-DENABLE_TESTS=ON
)