summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-17 17:29:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-17 17:53:14 +0200
commit4cf95c412621d88b6b72b431cc8d634de25f8fa4 (patch)
treecaac6b6d9bd188ecd90b14571e7c5d76565558b4 /sci-electronics/gazebo
parentdev-ros/realtime_tools: add missing include in public header (diff)
downloadgentoo-4cf95c412621d88b6b72b431cc8d634de25f8fa4.tar.gz
gentoo-4cf95c412621d88b6b72b431cc8d634de25f8fa4.tar.bz2
gentoo-4cf95c412621d88b6b72b431cc8d634de25f8fa4.zip
sci-electronics/gazebo: bump to 11.1.0
Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/files/boost174.patch20
-rw-r--r--sci-electronics/gazebo/gazebo-11.1.0.ebuild85
3 files changed, 106 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index bd4b17f4b6d4..48c83055e433 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,2 +1,3 @@
DIST gazebo-10.1.0.tar.bz2 52723379 BLAKE2B c7902c1797efef80b3110e988e1c01d171f652803a2ac28b880d5a01e2f981655db2d9925263030948d351e95af39d435b8618bf703f56a29033db05f0b29e2f SHA512 8febea84240eeb2367d783b36e4c626145ccf13177837ccb73b6ed87f8b264a337c6f8dc53d8583ce5d903b6152eaa5234ec2015ee292a1681800af2800d9eb7
DIST gazebo-11.0.0.tar.bz2 53806265 BLAKE2B 0658bdfd7d1f130767bd38cc2b33379f66f8cd92a9e6496581cd660638fb0307f87af19bcd5bd9ec2edb2be980e964297241ab4c1cec855751fdd7b394c717e9 SHA512 7c6cbb17c52829bb553f57a4bc2d515211aefa105d97cd5e71ff239244e49312562af1c901dac6c88b982986dd1318c0bb780c0a68f10ce78f25e12f031ba934
+DIST gazebo-11.1.0.tar.bz2 53856366 BLAKE2B 6e3df164e40c44265da68eae260012d873121631e56e9ae4ca3d8355e9c22ac80811549103e83d5f20d40f92c80f7a7a313c2395209b1c5177f518d0c0b2117c SHA512 39866991d8b996656a9f927a70e215175ecef671a1e317bfe9221df38bdc08be9825d36018da90cc6843480643a7716586ce8d61f36ffc8b4558ef7096ef6f76
diff --git a/sci-electronics/gazebo/files/boost174.patch b/sci-electronics/gazebo/files/boost174.patch
new file mode 100644
index 000000000000..82bbdf40f7a7
--- /dev/null
+++ b/sci-electronics/gazebo/files/boost174.patch
@@ -0,0 +1,20 @@
+Index: gazebo-11.1.0/plugins/SimpleTrackedVehiclePlugin.cc
+===================================================================
+--- gazebo-11.1.0.orig/plugins/SimpleTrackedVehiclePlugin.cc
++++ gazebo-11.1.0/plugins/SimpleTrackedVehiclePlugin.cc
+@@ -30,6 +30,7 @@
+
+ #include "plugins/SimpleTrackedVehiclePlugin.hh"
+
++#if BOOST_VERSION < 107400 || defined(BOOST_NO_CXX11_HDR_FUNCTIONAL)
+ namespace std {
+ template<class T>
+ class hash<boost::shared_ptr<T>> {
+@@ -38,6 +39,7 @@ class hash<boost::shared_ptr<T>> {
+ }
+ };
+ }
++#endif
+
+ namespace gazebo
+ {
diff --git a/sci-electronics/gazebo/gazebo-11.1.0.ebuild b/sci-electronics/gazebo/gazebo-11.1.0.ebuild
new file mode 100644
index 000000000000..ee7b5f268a7d
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-11.1.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/11"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb
+ >=dev-games/ogre-1.7.4:=[freeimage]
+ <dev-games/ogre-1.10
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ >=media-video/ffmpeg-2.6:0=
+ sci-libs/gts
+ >=sci-physics/bullet-2.82
+ >=dev-libs/sdformat-9.1:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=[threads]
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ media-gfx/graphviz
+ net-libs/ignition-msgs:5=
+ sci-libs/ignition-math:6=
+ net-libs/ignition-transport:8=
+ sci-libs/ignition-common:3=
+ sci-libs/ignition-fuel-tools:4=
+ x11-libs/qwt:6=[qt5(+)]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+BDEPEND="
+ app-text/ronn
+ app-arch/gzip
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=(
+ "${FILESDIR}/qwt.patch"
+ "${FILESDIR}/boost173.patch"
+ "${FILESDIR}/cmake.patch"
+ "${FILESDIR}/boost174.patch"
+)
+
+src_configure() {
+ # doesnt build with as-needed
+ #append-ldflags "-Wl,--no-as-needed"
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake-utils_src_configure
+}