summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-20 23:24:57 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-20 23:25:27 +0200
commit83191499c969a0fd64a515fdba5d0a5088a36ff2 (patch)
tree10753eeb934f69aea613943a40bd0aa13eedd652 /sci-electronics/gnucap
parentdev-libs/ossp-uuid: stable 1.6.2-r6 for hppa, bug #573940 (diff)
downloadgentoo-83191499c969a0fd64a515fdba5d0a5088a36ff2.tar.gz
gentoo-83191499c969a0fd64a515fdba5d0a5088a36ff2.tar.bz2
gentoo-83191499c969a0fd64a515fdba5d0a5088a36ff2.zip
sci-electronics/gnucap: Force -std=gnu++98 to fix build with gcc-6, bug 594184
The code is otherwise rather unfixable. Maybe one day somebody will have mercy and do a version bump. Closes: https://bugs.gentoo.org/594184 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sci-electronics/gnucap')
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.20091207.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild b/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
index 4affd99b9d65..ef828018d8f4 100644
--- a/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
+++ b/sci-electronics/gnucap/gnucap-0.35.20091207.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="2"
-inherit multilib toolchain-funcs
+inherit multilib toolchain-funcs flag-o-matic
SNAPSHOTDATE="${P##*.}"
MY_PV="${PN}-${SNAPSHOTDATE:0:4}-${SNAPSHOTDATE:4:2}-${SNAPSHOTDATE:6:2}"
@@ -51,6 +51,7 @@ src_prepare() {
{src,modelgen}/ap_match.cc || die "sed failed"
tc-export CC CXX
+ append-cxxflags -std=gnu++98
}
src_compile () {