summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-12-27 17:46:29 +0800
committerIan Delaney <idella4@gentoo.org>2015-12-27 18:08:05 +0800
commit511f0ae95ef4e3a44c74a045f1c55d46270d21cc (patch)
tree138f7d5f5eb3196309c806af58e1ad96611896ac /sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild
parentMerge remote-tracking branch 'remotes/operatornormal/gentoo_bug_568874' (diff)
downloadgentoo-511f0ae95ef4e3a44c74a045f1c55d46270d21cc.tar.gz
gentoo-511f0ae95ef4e3a44c74a045f1c55d46270d21cc.tar.bz2
gentoo-511f0ae95ef4e3a44c74a045f1c55d46270d21cc.zip
sci-electronics/quartus-prime-lite: New package to be maintained by 'undersys'
ebuild by undersys and will be proxy maintainer under management of the proxy-maintainers project: - comes with a new license entitled "Quartus-prime-megacore", checked and endorsed by license team, - license is of type EULA and has been added to license groups accordingly, - this is a binary packagem installs into /opt, - user need d'load tarball separately, restrict set with fetch & bindinst, - ebuild prepared and reviewd by members of proxy maintaines & ulm - all ebuild revisions and patches submitted via the gentoo bug Gentoo bug :#569302 Package-Manager: portage-2.2.24
Diffstat (limited to 'sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild')
-rw-r--r--sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild b/sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild
new file mode 100644
index 000000000000..395c34ee4215
--- /dev/null
+++ b/sci-electronics/quartus-prime-lite/quartus-prime-lite-15.1.0.185.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Full-featured EDA product for altera devices"
+HOMEPAGE="https://www.altera.com/products/design-software/fpga-design/quartus-prime/overview.html"
+SRC_URI="Quartus-lite-${PV}-linux.tar"
+# variable to store the download URL
+DOWNLOADPAGE="http://dl.altera.com/?edition=lite"
+
+LICENSE="Quartus-prime-megacore"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libpng:1.2"
+
+RESTRICT="fetch bindist"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ elog "Due to licensing restrictions, you need to download the distfile manually."
+ elog "Please navigate to ${DOWNLOADPAGE}"
+ elog "Sign in with your Altera account (you need to register)"
+ elog "Download ${SRC_URI} and place it into ${DISTDIR}"
+ elog "And restart the installation."
+}
+
+pkg_pretend() {
+ einfo "The checksum and unpack will take quite some time to run"
+}
+
+src_install() {
+ einfo "The Quartus install runs in unattended mode"
+ einfo "you wont see much and it will take a long time"
+
+ ./setup.sh --mode unattended --unattendedmodeui none \
+ --installdir "${D}/opt/quartus-lite-${PV}"
+ make_desktop_entry "/opt/quartus-lite-${PV}/quartus/bin/quartus" \
+ "Quartus lite ${PV}" "/opt/quartus-lite-${PV}/quartus/adm/quartusii.png"
+}
+
+pkg_postinst() {
+ elog "To launch Quartus, run /opt/quartus-lite-${PV}/quartus/bin/quartus"
+}