summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-15 17:13:05 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-15 17:22:30 +0100
commit1a337adf42acfd62559dd715544195f5ddd53058 (patch)
tree0b0b2fd0baa941a9bc26e7b95ea442bf4b9d6a2b /sci-electronics/qucs
parentsci-electronics/qucs: Un-force -g, -O0 and -s flag mangling (diff)
downloadgentoo-1a337adf42acfd62559dd715544195f5ddd53058.tar.gz
gentoo-1a337adf42acfd62559dd715544195f5ddd53058.tar.bz2
gentoo-1a337adf42acfd62559dd715544195f5ddd53058.zip
sci-electronics/qucs: Support USE=debug
Diffstat (limited to 'sci-electronics/qucs')
-rw-r--r--sci-electronics/qucs/qucs-0.0.18.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-electronics/qucs/qucs-0.0.18.ebuild b/sci-electronics/qucs/qucs-0.0.18.ebuild
index d2ef71f5cd0b..7552aa0431ea 100644
--- a/sci-electronics/qucs/qucs-0.0.18.ebuild
+++ b/sci-electronics/qucs/qucs-0.0.18.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="debug"
RDEPEND="dev-qt/qtcore:4[qt3support]
dev-qt/qtgui:4[qt3support]
@@ -39,6 +39,11 @@ src_prepare() {
}
src_configure() {
+ local myconf=(
+ # enables asserts and debug codepaths
+ $(use_enable debug)
+ )
+
# automagic default on clang++
tc-export CXX
@@ -47,7 +52,7 @@ src_configure() {
append-ldflags $( $(tc-getPKG_CONFIG) --libs-only-L \
QtCore QtGui QtScript QtSvg QtXml Qt3Support )
- default
+ econf "${myconf[@]}"
}
pkg_postinst() {