summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 19:55:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:35:22 +0100
commit495170f86afa8156fea97d4aa5668ffc5aff3290 (patch)
treeb891d800e7b9b5f58d86fa034a37ab87dd5fe180 /sci-electronics
parentsci-chemistry/vmd: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-495170f86afa8156fea97d4aa5668ffc5aff3290.tar.gz
gentoo-495170f86afa8156fea97d4aa5668ffc5aff3290.tar.bz2
gentoo-495170f86afa8156fea97d4aa5668ffc5aff3290.zip
sci-electronics/geda-xgsch2pcb: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r5.ebuild (renamed from sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r3.ebuild)16
-rw-r--r--sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r6.ebuild (renamed from sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r4.ebuild)10
2 files changed, 17 insertions, 9 deletions
diff --git a/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r3.ebuild b/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r5.ebuild
index e7beae977e1c..f7db10a7e691 100644
--- a/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r3.ebuild
+++ b/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,16 +19,22 @@ IUSE="gnome nls"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
CDEPEND="${PYTHON_DEPS}
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ ')
sci-electronics/pcb[dbus]
sci-electronics/geda
nls? ( virtual/libintl )
"
RDEPEND="${CDEPEND}
sci-electronics/electronics-menu
- gnome? ( dev-python/gnome-vfs-python[${PYTHON_USEDEP}] )
+ gnome? (
+ $(python_gen_cond_dep '
+ dev-python/gnome-vfs-python[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
DEPEND="${CDEPEND}
dev-util/intltool
diff --git a/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r4.ebuild b/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r6.ebuild
index 44789cb25430..b9b2d426a6ae 100644
--- a/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r4.ebuild
+++ b/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,9 +19,11 @@ IUSE="nls"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
CDEPEND="${PYTHON_DEPS}
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ ')
sci-electronics/pcb[dbus]
sci-electronics/geda
nls? ( virtual/libintl )