summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-09 14:50:51 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-09 14:51:11 +0200
commit54302103d89b42d207c50407dc0ccbb20515cf4b (patch)
tree81aea7cbd3e8cd1d384628818f3a446b56d32b0f /sci-electronics
parentdev-libs/svrcore: Bump #583780 (diff)
downloadgentoo-54302103d89b42d207c50407dc0ccbb20515cf4b.tar.gz
gentoo-54302103d89b42d207c50407dc0ccbb20515cf4b.tar.bz2
gentoo-54302103d89b42d207c50407dc0ccbb20515cf4b.zip
sci-electronics/gerbv: Version bump.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gerbv/Manifest1
-rw-r--r--sci-electronics/gerbv/files/gerbv-2.6.1-ru.patch12
-rw-r--r--sci-electronics/gerbv/gerbv-2.6.1.ebuild66
3 files changed, 79 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/Manifest b/sci-electronics/gerbv/Manifest
index eb77eccf63d1..f3faad2c8d0c 100644
--- a/sci-electronics/gerbv/Manifest
+++ b/sci-electronics/gerbv/Manifest
@@ -1 +1,2 @@
DIST gerbv-2.6.0.tar.gz 2346299 SHA256 5c55425c3493bc8407949be8b4e572434a6b378f5727cc0dcef97dc2e7574dd0 SHA512 a2d7601b44c8ed16a89d18713f451c0298bee65e2ea76b87e3d9d573af63d3b57758cb7cfcfb2177a22aecc7d9fdaaca3d369ea051446651af4dc542065a4377 WHIRLPOOL 07fd10e35d7f384bfdf8d16c9e1a42bdf3010dcd45c2cb3cb359f7c0478b0739c784900e8448c117841511e7d6fed2fe5bd69051fd61e2c64750f83e931909c4
+DIST gerbv-2.6.1.tar.gz 4432481 SHA256 7aa6a2c622dc9ff7acd88411dddf95ae25ae3b5d97020f3ea91e97d82bf0d96c SHA512 cbf4ce4fd2b401d65ffc6bb5a7f9da0e6fa31cb3f754ea12092c86f197c72c833805eb395562b286f6d03c2eb38e363b649f8aa1040a6207baf975fa15e48b29 WHIRLPOOL c59feee8a6c5879cf9686bebb79adcd15b55d73e65641866c90c85d8b757113a7e119cf3b58f08f40e8c0c532fde23411ed9245ee0b011698364da974f9b65fa
diff --git a/sci-electronics/gerbv/files/gerbv-2.6.1-ru.patch b/sci-electronics/gerbv/files/gerbv-2.6.1-ru.patch
new file mode 100644
index 000000000000..a56f34333919
--- /dev/null
+++ b/sci-electronics/gerbv/files/gerbv-2.6.1-ru.patch
@@ -0,0 +1,12 @@
+--- a/man/Makefile.am
++++ b/man/Makefile.am
+@@ -19,8 +19,7 @@
+ ## along with this program; if not, write to the Free Software
+ ## Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111 USA
+
+-man_MANS = gerbv.1 gerbv.ru.1
+-PO_FILES= gerbv.ru.1.in.po
++man_MANS = gerbv.1
+
+ MOSTLYCLEANFILES = *~
+ CLEANFILES = *~ *.pot $(man_MANS)
diff --git a/sci-electronics/gerbv/gerbv-2.6.1.ebuild b/sci-electronics/gerbv/gerbv-2.6.1.ebuild
new file mode 100644
index 000000000000..056c74e40102
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-2.6.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit autotools eutils fdo-mime
+
+DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gerbv.geda-project.org/"
+
+IUSE="doc examples static-libs unit-mm"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/cairo"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # No Russian translation shipped
+ echo > po/LINGUAS || die
+ eapply "${FILESDIR}"/${P}-ru.patch
+
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable unit-mm) \
+ --disable-update-desktop-database
+}
+
+src_install () {
+ default
+
+ dodoc AUTHORS BUGS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
+
+ rm doc/Doxyfile.nopreprocessing
+ if use doc; then
+ find doc -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r doc/*
+ fi
+
+ if use examples; then
+ find example -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r example/*
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}