summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 04:59:34 +0100
committerSam James <sam@gentoo.org>2021-10-17 04:59:34 +0100
commit1caddd2c85b8c9d6c90d414170dec987000e34a7 (patch)
treeb21708f7db2c1a241c5a3031d0f7ee56492317c7 /sci-geosciences/foxtrotgps
parentdev-lang/go: Stabilize 1.17.2 ppc64, #817902 (diff)
downloadgentoo-1caddd2c85b8c9d6c90d414170dec987000e34a7.tar.gz
gentoo-1caddd2c85b8c9d6c90d414170dec987000e34a7.tar.bz2
gentoo-1caddd2c85b8c9d6c90d414170dec987000e34a7.zip
sci-geosciences/foxtrotgps: fix build with newer gpsd
Closes: https://bugs.gentoo.org/739568 Closes: https://bugs.gentoo.org/806986 Closes: https://bugs.gentoo.org/808883 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/foxtrotgps')
-rw-r--r--sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch29
-rw-r--r--sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild2
2 files changed, 19 insertions, 12 deletions
diff --git a/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch b/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
index 23930212f31f..c84ea65b77e0 100644
--- a/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
+++ b/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
@@ -1,33 +1,40 @@
-From ea27c684924b8d8a560ca6fe1f25443624d54a93 Mon Sep 17 00:00:00 2001
+https://bugs.gentoo.org/739568
+https://bugs.gentoo.org/806986
+https://bugs.gentoo.org/808883
+
+From 86989085a3010cb83a094a788cd83a4654c9eb3c Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Wed, 18 Aug 2021 20:18:03 +0100
-Subject: [PATCH] Fix some GPS receivers
+Subject: [PATCH] Fix some GPS receivers (and fix build with newer gpsd API 12)
Rebased version of upstream patch:
https://bazaar.launchpad.net/~foxtrotgps-team/foxtrotgps/trunk/revision/329
-Conservatively added an extra API version check for gpsd.
+See https://github.com/ntpsec/gpsd/commit/d4a4d8d3606fd50f10bcd20096a8a0cdb8b2d427
+re API change.
Bug: https://bugs.gentoo.org/808883
---
- src/gps_functions.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
+ src/gps_functions.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/gps_functions.c b/src/gps_functions.c
-index 602b06e..4f30cbb 100644
+index 602b06e..0baea81 100644
--- a/src/gps_functions.c
+++ b/src/gps_functions.c
-@@ -762,7 +762,9 @@ cb_gpsd_data(GIOChannel *src, GIOCondition condition, gpointer data)
+@@ -762,8 +762,10 @@ cb_gpsd_data(GIOChannel *src, GIOCondition condition, gpointer data)
{
gpsdata->fix.time = (time_t) 0;
}
-#if GPSD_API_MAJOR_VERSION >= 9
-+#if GPSD_API_MAJOR_VERSION >= 10
+- gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX);
++#if GPSD_API_MAJOR_VERSION >= 12
++ gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_UNK || libgps_gpsdata.fix.mode >= MODE_2D);
++#elif GPSD_API_MAJOR_VERSION >= 10
+ gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX || libgps_gpsdata.fix.mode >= MODE_2D);
-+#elif GPSD_API_MAJOR_VERSION >= 9
- gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX);
#else
gpsdata->valid = (libgps_gpsdata.status != STATUS_NO_FIX);
+ #endif
--
-2.33.0
+2.33.1
diff --git a/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
index cc36b1da8d8e..9810966d440d 100644
--- a/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
+++ b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
@@ -30,5 +30,5 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${P}-gpsd-api9.patch"
"${FILESDIR}/${P}-gcc10.patch"
- "${FILESDIR}/${P}-fix-some-receivers.patch"
+ #"${FILESDIR}/${P}-fix-some-receivers.patch"
)