summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-11-08 17:15:20 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-09 08:59:25 +0100
commitca0095f225504a3dbadb85d80a3e92eebfd634c2 (patch)
treec8be959fa56358a4bf8ae3b6cb641650c66c40e5 /sci-geosciences/gnome-maps/gnome-maps-3.22.2.ebuild
parentDrop old (diff)
downloadgentoo-ca0095f225504a3dbadb85d80a3e92eebfd634c2.tar.gz
gentoo-ca0095f225504a3dbadb85d80a3e92eebfd634c2.tar.bz2
gentoo-ca0095f225504a3dbadb85d80a3e92eebfd634c2.zip
sci-geosciences/gnome-maps: add gnome-maps-3.22.2.ebuild
Bump from 3.22.1 as no relevant duff https://git.gnome.org//browse/gnome-maps/diff/?id=v3.22.2&&id2=v3.22.1 Closes: https://github.com/gentoo/gentoo/pull/2784 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'sci-geosciences/gnome-maps/gnome-maps-3.22.2.ebuild')
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-3.22.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/gnome-maps-3.22.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-3.22.2.ebuild
new file mode 100644
index 000000000000..1ed2cc652863
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-3.22.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=dev-libs/folks-0.10
+ >=dev-libs/gjs-1.44.0
+ >=dev-libs/gobject-introspection-0.6.3:=
+ >=dev-libs/glib-2.39.3:2
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ dev-libs/libxml2:2
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ net-libs/rest:0.7[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=x11-libs/gtk+-3.15.9:3[introspection]
+"
+# Found by grepping imports.gi in ${S}
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ media-libs/cogl:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"