summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-07-18 11:45:05 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-18 11:45:16 +0300
commit6b17f035964e92106f9a44349e88a2cdbee4e588 (patch)
treebaa4dc976df983ce0c0e0d608dadd3b9dfbe6a48 /sci-geosciences/gnome-maps
parentgnome-extra/gnome-logs: bump to 3.36.0 (diff)
downloadgentoo-6b17f035964e92106f9a44349e88a2cdbee4e588.tar.gz
gentoo-6b17f035964e92106f9a44349e88a2cdbee4e588.tar.bz2
gentoo-6b17f035964e92106f9a44349e88a2cdbee4e588.zip
sci-geosciences/gnome-maps: bump to 3.36.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'sci-geosciences/gnome-maps')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-3.36.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 91683f866d97..fd38f022d59c 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1 +1,2 @@
DIST gnome-maps-3.34.3.tar.xz 3976776 BLAKE2B e01c18be2b48b90f88159828a046e3c422a56557f198595985ba39053ffdc85d60eebbf21d37ab1e4bb2eae8d1ad93c76b199650b713eba7a937674be38c845f SHA512 63261fb77ea1260aacaf502950f89ba6e5294271526b25302258df4fb40f4e04e3a4697750b2f7238f45a8d4bdbe9e583d45a4de02ce178e8f6716b44a7c8ba0
+DIST gnome-maps-3.36.4.tar.xz 4006520 BLAKE2B 4fb76e23580556c357c5a4a246a250521472a4b264264ea0e6172b2a61583f63e297fef29060b1b30a8978e509820d22eda2e6d56eda69f97e25e9795dcf38b2 SHA512 530ccc0a25c0a1fee2411ecc4034981210836664acc7adc6aa9cff9304e2499c1205f9c27b6b692fdee152fe1750541a1966d59a60958f3592682a5e110d490f
diff --git a/sci-geosciences/gnome-maps/gnome-maps-3.36.4.ebuild b/sci-geosciences/gnome-maps/gnome-maps-3.36.4.ebuild
new file mode 100644
index 000000000000..cb8141452d75
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-3.36.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.50.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}