summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild')
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild
new file mode 100644
index 000000000000..08db006bd4db
--- /dev/null
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.4.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils qt4-r2 autotools
+
+DESCRIPTION="GPS waypoints, tracks and routes converter"
+HOMEPAGE="http://www.gpsbabel.org/"
+SRC_URI="
+ mirror://gentoo/${P}.tar.gz
+ doc? ( http://www.gpsbabel.org/style3.css -> gpsbabel.org-style3.css )"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE="doc qt4"
+
+RDEPEND="
+ dev-libs/expat
+ sci-libs/shapelib
+ virtual/libusb:0
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-lang/perl
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.1.2
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-disable_statistic_uploading.patch"
+ "${FILESDIR}/${PN}-disable_update_check.patch"
+ "${FILESDIR}/${PN}-disable_version_check.patch"
+ "${FILESDIR}/${P}-fix_binary_name.patch"
+ "${FILESDIR}/${PN}-freebsd.patch"
+ "${FILESDIR}/${PN}-use_system_shapelib.patch"
+ "${FILESDIR}/${PN}-xmldoc.patch"
+)
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+ epatch_user
+ rm -rf shapelib || die
+
+ use doc && cp "${DISTDIR}/gpsbabel.org-style3.css" "${S}"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with doc doc "${S}"/doc/manual) \
+ --with-zlib=system
+
+ if use qt4; then
+ pushd "${S}/gui" > /dev/null || die
+ lrelease *.ts || die
+ eqmake4
+ popd > /dev/null
+ fi
+}
+
+src_compile() {
+ emake
+ if use qt4; then
+ pushd "${S}/gui" > /dev/null || die
+ emake
+ popd > /dev/null
+ fi
+
+ if use doc; then
+ perl xmldoc/makedoc || die
+ emake gpsbabel.html
+ fi
+}
+
+src_install() {
+ default
+ dodoc README*
+
+ if use qt4; then
+ dobin gui/objects/gpsbabelfe
+ insinto /usr/share/qt4/translations/
+ doins gui/gpsbabel*_*.qm
+ newicon gui/images/appicon.png ${PN}.png
+ make_desktop_entry gpsbabelfe ${PN} ${PN} "Science;Geoscience"
+ fi
+
+ if use doc; then
+ dohtml gpsbabel.*
+ fi
+}