summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-18 19:39:39 +0100
committerSam James <sam@gentoo.org>2021-08-18 20:22:50 +0100
commitf268b9b67d24bcf1f6d6e376ffa9c5d30bc758f6 (patch)
treec0b3cdb1668c82aff150b86612fb7f90d17deb17 /sci-geosciences/gpsd
parentmedia-libs/woff2: add missing brotli subslot dep (diff)
downloadgentoo-f268b9b67d24bcf1f6d6e376ffa9c5d30bc758f6.tar.gz
gentoo-f268b9b67d24bcf1f6d6e376ffa9c5d30bc758f6.tar.bz2
gentoo-f268b9b67d24bcf1f6d6e376ffa9c5d30bc758f6.zip
sci-geosciences/gpsd: fix Python modules
Thanks-to: Maciej S. Szmigiero <mail@maciej.szmigiero.name> Closes: https://bugs.gentoo.org/808805 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.23-r1.ebuild (renamed from sci-geosciences/gpsd/gpsd-3.23.ebuild)6
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.23.ebuild b/sci-geosciences/gpsd/gpsd-3.23-r1.ebuild
index f21d1e6662f4..c7a6204d9196 100644
--- a/sci-geosciences/gpsd/gpsd-3.23.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.23-r1.ebuild
@@ -187,7 +187,10 @@ src_compile() {
export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
escons "${scons_opts[@]}"
+ pushd "${P}" || die
+ ln -sf ../setup.py . || die
use python && distutils-r1_src_compile
+ popd || die
}
src_install() {
@@ -200,6 +203,7 @@ src_install() {
rm -rf "${D}"/python-discard/gps*
find "${D}"/python-discard/ -type d -delete
# Install correct multi-python copy
+ pushd "${P}" || die
use python && distutils-r1_src_install
-
+ popd || die
}
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index f21d1e6662f4..c7a6204d9196 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -187,7 +187,10 @@ src_compile() {
export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
escons "${scons_opts[@]}"
+ pushd "${P}" || die
+ ln -sf ../setup.py . || die
use python && distutils-r1_src_compile
+ popd || die
}
src_install() {
@@ -200,6 +203,7 @@ src_install() {
rm -rf "${D}"/python-discard/gps*
find "${D}"/python-discard/ -type d -delete
# Install correct multi-python copy
+ pushd "${P}" || die
use python && distutils-r1_src_install
-
+ popd || die
}