summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2015-10-23 17:43:29 +0200
committerAmy Winston <amynka@gentoo.org>2015-10-23 17:43:29 +0200
commit291b79be78175ee4087496bafbb015817d6294b6 (patch)
treea5e432b3125c5fc84cedb8e80776cc79a316fd67 /sci-geosciences/laszip/laszip-2.2.0.ebuild
parentsci-libs/armadillo: Version bump, major version (diff)
downloadgentoo-291b79be78175ee4087496bafbb015817d6294b6.tar.gz
gentoo-291b79be78175ee4087496bafbb015817d6294b6.tar.bz2
gentoo-291b79be78175ee4087496bafbb015817d6294b6.zip
sci-geosciences/laszip: Initial commit. Dependency for grass7. By wraeth.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-geosciences/laszip/laszip-2.2.0.ebuild')
-rw-r--r--sci-geosciences/laszip/laszip-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-geosciences/laszip/laszip-2.2.0.ebuild b/sci-geosciences/laszip/laszip-2.2.0.ebuild
new file mode 100644
index 000000000000..0003ae67553e
--- /dev/null
+++ b/sci-geosciences/laszip/laszip-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="Library for free and lossless compression of the LAS LiDAR format"
+HOMEPAGE="http://www.laszip.org/"
+SRC_URI="https://github.com/LASzip/LASzip/releases/download/v${PV}/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-src-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}_fix-build-system.patch
+)
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ autotools-utils_src_configure
+}