summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 11:03:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-05 18:40:23 +0100
commit26f7969f0ff20bdf16ba2c1fd294900521e6a840 (patch)
tree45b57196276572b30902ae2faf16b3b81a6196e6 /sci-geosciences/liblas
parentsys-apps/pcsc-lite: Version bump (v1.8.26) (diff)
downloadgentoo-26f7969f0ff20bdf16ba2c1fd294900521e6a840.tar.gz
gentoo-26f7969f0ff20bdf16ba2c1fd294900521e6a840.tar.bz2
gentoo-26f7969f0ff20bdf16ba2c1fd294900521e6a840.zip
sci-geosciences: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences/liblas')
-rw-r--r--sci-geosciences/liblas/liblas-1.8.1-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild b/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild
index 377be29abea5..949af96ab07b 100644
--- a/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild
+++ b/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C/C++ library for manipulating the LAS LiDAR format common in GIS"
HOMEPAGE="https://github.com/libLAS/libLAS/"
@@ -34,7 +34,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# add missing linkage
sed -e 's:${LAS2COL} ${LIBLAS_C_LIB_NAME}:& ${CMAKE_THREAD_LIBS_INIT}:' \
@@ -46,5 +46,5 @@ src_configure() {
-DLIBLAS_LIB_SUBDIR=$(get_libdir)
-DWITH_GDAL=$(usex gdal)
)
- cmake-utils_src_configure
+ cmake_src_configure
}