summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 15:06:40 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 17:24:48 +0200
commit292e1386ca002aa1bea44374924204e8ebd5c9fd (patch)
tree1fd97b062958180d52c9566f4584b8e4c6a0e439 /sci-geosciences/qgis/qgis-9999.ebuild
parentRevert "media-libs/aubio[doc]: package.use.mask" (diff)
downloadgentoo-292e1386ca002aa1bea44374924204e8ebd5c9fd.tar.gz
gentoo-292e1386ca002aa1bea44374924204e8ebd5c9fd.tar.bz2
gentoo-292e1386ca002aa1bea44374924204e8ebd5c9fd.zip
sci-geosciences/qgis: 3.10.7 version bump
Contains upstream fixes for build with Qt 5.15 and PyQt5 5.15. Closes: https://bugs.gentoo.org/712684 Closes: https://bugs.gentoo.org/716486 Closes: https://bugs.gentoo.org/727746 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences/qgis/qgis-9999.ebuild')
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild40
1 files changed, 19 insertions, 21 deletions
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index 74129055f6bb..1d92f9dc32d7 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"
-QT_MIN_VER="5.9.4"
+QTMIN="5.9.4"
if [[ ${PV} = *9999 ]]; then
EGIT_REPO_URI="https://github.com/${PN}/${PN^^}.git"
@@ -26,9 +26,8 @@ IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
-BDEPEND="
- ${PYTHON_DEPS}
- >=dev-qt/linguist-tools-${QT_MIN_VER}:5
+BDEPEND="${PYTHON_DEPS}
+ >=dev-qt/linguist-tools-${QTMIN}:5
sys-devel/bison
sys-devel/flex
"
@@ -39,26 +38,26 @@ COMMON_DEPEND="
dev-libs/expat
dev-libs/libzip:=
dev-libs/qtkeychain[qt5(+)]
- >=dev-qt/designer-${QT_MIN_VER}:5
- >=dev-qt/qtconcurrent-${QT_MIN_VER}:5
- >=dev-qt/qtcore-${QT_MIN_VER}:5
- >=dev-qt/qtgui-${QT_MIN_VER}:5
- >=dev-qt/qtnetwork-${QT_MIN_VER}:5[ssl]
- >=dev-qt/qtpositioning-${QT_MIN_VER}:5
- >=dev-qt/qtprintsupport-${QT_MIN_VER}:5
- >=dev-qt/qtserialport-${QT_MIN_VER}:5
- >=dev-qt/qtsvg-${QT_MIN_VER}:5
- >=dev-qt/qtsql-${QT_MIN_VER}:5
- >=dev-qt/qtwidgets-${QT_MIN_VER}:5
- >=dev-qt/qtxml-${QT_MIN_VER}:5
+ >=dev-qt/designer-${QTMIN}:5
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtpositioning-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtserialport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
media-gfx/exiv2:=
>=sci-libs/gdal-3.0.4:=[geos]
sci-libs/geos
sci-libs/libspatialindex:=
- >=sci-libs/proj-4.9.3:=
+ >=sci-libs/proj-6.3.1:=
>=x11-libs/qscintilla-2.10.1:=[qt5(+)]
>=x11-libs/qwt-6.1.2:6=[qt5(+),svg]
- 3d? ( >=dev-qt/qt3d-${QT_MIN_VER}:5 )
+ 3d? ( >=dev-qt/qt3d-${QTMIN}:5 )
georeferencer? ( sci-libs/gsl:= )
grass? ( =sci-geosciences/grass-7*:= )
hdf5? ( sci-libs/hdf5:= )
@@ -92,12 +91,11 @@ COMMON_DEPEND="
postgres? ( dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}] )
')
)
- qml? ( >=dev-qt/qtdeclarative-${QT_MIN_VER}:5 )
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
"
DEPEND="${COMMON_DEPEND}
- >=dev-qt/qttest-${QT_MIN_VER}:5
- python? ( ${PYTHON_DEPS} )
+ >=dev-qt/qttest-${QTMIN}:5
"
RDEPEND="${COMMON_DEPEND}
sci-geosciences/gpsbabel