summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-06-22 21:43:54 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-06-22 21:43:54 +0700
commit2584225aa4c049215322e2919bbf8acfbaae3068 (patch)
tree93041d2f87dd638eecb5153be0193e40ff240bb2 /sci-geosciences/qmapshack
parentnet-wireless/inspectrum: Fix build with Qt 5.15 (diff)
downloadgentoo-2584225aa4c049215322e2919bbf8acfbaae3068.tar.gz
gentoo-2584225aa4c049215322e2919bbf8acfbaae3068.tar.bz2
gentoo-2584225aa4c049215322e2919bbf8acfbaae3068.zip
sci-geosciences/qmapshack: bump to 1.15
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/qmapshack')
-rw-r--r--sci-geosciences/qmapshack/Manifest1
-rw-r--r--sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch67
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.15.0.ebuild45
3 files changed, 113 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index 940fd018d398..610083c3bea8 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1,2 +1,3 @@
DIST qmapshack-1.14.0.tar.gz 12541988 BLAKE2B 146df8ab42bd5a5249207b88bf1a17b4ba20706c8114cc059b847d0b32c9d53919f931d778402a10dd62f0d86948bff8eefd29684c433c1d4bfd7e2ce019ce55 SHA512 675a72a79839ad0b96fc0717ad7eca43c4ce331645ba3ad1325f9bf114abcf2ecd164eeab0c41775fe84aa626fc67272cd9c869047f57b225ff493f66881ff99
DIST qmapshack-1.14.1.tar.gz 12541988 BLAKE2B 146df8ab42bd5a5249207b88bf1a17b4ba20706c8114cc059b847d0b32c9d53919f931d778402a10dd62f0d86948bff8eefd29684c433c1d4bfd7e2ce019ce55 SHA512 675a72a79839ad0b96fc0717ad7eca43c4ce331645ba3ad1325f9bf114abcf2ecd164eeab0c41775fe84aa626fc67272cd9c869047f57b225ff493f66881ff99
+DIST qmapshack-1.15.0.tar.gz 46097781 BLAKE2B 16db9c59bd669e55dbb67af0411570963ff6a59f24c75d62421540fa1437cbc4dd837cf115b2649b3482e191ae11040b567f34babbf9ad46bb09114727ad4ae9 SHA512 92e2b40c37cccbb4848dab1afd872d3cb29b4a162d44d57a1042ea0d5139ffc976bc02407d327b6f5cd3e0d08dbd526661fcbc0e05602fda15f78fd9bbce52cb
diff --git a/sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch b/sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch
new file mode 100644
index 000000000000..08d8946f69d4
--- /dev/null
+++ b/sci-geosciences/qmapshack/files/qmapshack-qt-5.15.patch
@@ -0,0 +1,67 @@
+diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/gis/wpt/CGisItemWpt.cpp qmapshack-V_1.15.0/src/qmapshack/gis/wpt/CGisItemWpt.cpp
+--- qmapshack-V_1.15.0.orig/src/qmapshack/gis/wpt/CGisItemWpt.cpp 2020-06-14 17:22:49.000000000 +0700
++++ qmapshack-V_1.15.0/src/qmapshack/gis/wpt/CGisItemWpt.cpp 2020-06-22 17:41:58.776553045 +0700
+@@ -38,6 +38,7 @@
+
+ #include <QtWidgets>
+ #include <QtXml>
++#include <QPainterPath>
+
+ IGisItem::key_t CGisItemWpt::keyUserFocus;
+ QMap<searchProperty_e, CGisItemWpt::fSearch> CGisItemWpt::keywordLambdaMap;
+diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/helpers/CDraw.cpp qmapshack-V_1.15.0/src/qmapshack/helpers/CDraw.cpp
+--- qmapshack-V_1.15.0.orig/src/qmapshack/helpers/CDraw.cpp 2020-06-14 17:22:49.000000000 +0700
++++ qmapshack-V_1.15.0/src/qmapshack/helpers/CDraw.cpp 2020-06-22 17:45:43.431558615 +0700
+@@ -24,6 +24,7 @@
+ #include <QImage>
+ #include <QPointF>
+ #include <QtMath>
++#include <QPainterPath>
+
+ QPen CDraw::penBorderBlue(QColor(10, 10, 150, 220), 2);
+ QPen CDraw::penBorderGray(Qt::lightGray, 2);
+diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/map/CMapIMG.cpp qmapshack-V_1.15.0/src/qmapshack/map/CMapIMG.cpp
+--- qmapshack-V_1.15.0.orig/src/qmapshack/map/CMapIMG.cpp 2020-06-14 17:22:49.000000000 +0700
++++ qmapshack-V_1.15.0/src/qmapshack/map/CMapIMG.cpp 2020-06-22 17:47:21.413561045 +0700
+@@ -33,6 +33,7 @@
+ #include "units/IUnit.h"
+
+ #include <QtWidgets>
++#include <QPainterPath>
+
+ #undef DEBUG_SHOW_SECT_DESC
+ #undef DEBUG_SHOW_TRE_DATA
+diff -U3 -r qmapshack-V_1.15.0.orig/src/qmapshack/mouse/IMouseSelect.cpp qmapshack-V_1.15.0/src/qmapshack/mouse/IMouseSelect.cpp
+--- qmapshack-V_1.15.0.orig/src/qmapshack/mouse/IMouseSelect.cpp 2020-06-14 17:22:49.000000000 +0700
++++ qmapshack-V_1.15.0/src/qmapshack/mouse/IMouseSelect.cpp 2020-06-22 17:43:31.338555340 +0700
+@@ -23,6 +23,7 @@
+ #include "mouse/IScrOpt.h"
+
+ #include <QtWidgets>
++#include <QPainterPath>
+
+ IMouseSelect::IMouseSelect(CGisDraw *gis, CCanvas *canvas, CMouseAdapter *mouse)
+ : IMouse(gis, canvas, mouse)
+diff -U3 -r qmapshack-V_1.15.0.orig/src/qmaptool/helpers/CDraw.cpp qmapshack-V_1.15.0/src/qmaptool/helpers/CDraw.cpp
+--- qmapshack-V_1.15.0.orig/src/qmaptool/helpers/CDraw.cpp 2020-06-14 17:22:49.000000000 +0700
++++ qmapshack-V_1.15.0/src/qmaptool/helpers/CDraw.cpp 2020-06-22 17:49:14.789563856 +0700
+@@ -24,6 +24,7 @@
+ #include <QImage>
+ #include <QPointF>
+ #include <QtMath>
++#include <QPainterPath>
+
+ QPen CDraw::penBorderBlue(QColor(10,10,150,220),2);
+ QPen CDraw::penBorderGray(Qt::lightGray,2);
+diff -U3 -r qmapshack-V_1.15.0.orig/src/qmaptool/overlay/COverlayCutMap.cpp qmapshack-V_1.15.0/src/qmaptool/overlay/COverlayCutMap.cpp
+--- qmapshack-V_1.15.0.orig/src/qmaptool/overlay/COverlayCutMap.cpp 2020-06-14 17:22:49.000000000 +0700
++++ qmapshack-V_1.15.0/src/qmaptool/overlay/COverlayCutMap.cpp 2020-06-22 17:50:08.109565178 +0700
+@@ -24,6 +24,8 @@
+
+ #include <functional>
+ #include <QtWidgets>
++#include <QPainterPath>
++
+ using std::bind;
+
+ static inline qreal sqr(qreal a)
diff --git a/sci-geosciences/qmapshack/qmapshack-1.15.0.ebuild b/sci-geosciences/qmapshack/qmapshack-1.15.0.ebuild
new file mode 100644
index 000000000000..1d7bf8e6abf5
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.15.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
+SRC_URI="https://github.com/Maproom/${PN}/archive/V_1.15.0.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtpositioning:5
+ dev-qt/qtdbus:5
+ dev-qt/qttest:5
+ dev-qt/designer:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qthelp:5
+ dev-libs/quazip
+ >=sci-geosciences/routino-3.1.1
+ sci-libs/gdal
+ >=sci-libs/proj-6.0.0:=
+ sci-libs/alglib"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=( "${FILESDIR}"/${PN}-positioning.patch "${FILESDIR}"/${PN}-qt-5.15.patch )
+S="${WORKDIR}"/${PN}-V_${PV}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ cp "${FILESDIR}"/FindPROJ4.cmake cmake/Modules/ || die
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/html
+ cmake-utils_src_install
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
+}