summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 01:51:09 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 01:51:09 +0200
commit2af1f0ec4c0d3261b757a88570308fbbb4dd0939 (patch)
treeee0ac79119b60db9242e24da5eb7ab77e3aa015c /sci-geosciences/seawater/seawater-3.3.4.ebuild
parentdev-util/a8: version bump to 1.0 (diff)
downloadgentoo-2af1f0ec4c0d3261b757a88570308fbbb4dd0939.tar.gz
gentoo-2af1f0ec4c0d3261b757a88570308fbbb4dd0939.tar.bz2
gentoo-2af1f0ec4c0d3261b757a88570308fbbb4dd0939.zip
sci-geosciences/seawater: version bump to 3.3.4
Diffstat (limited to 'sci-geosciences/seawater/seawater-3.3.4.ebuild')
-rw-r--r--sci-geosciences/seawater/seawater-3.3.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-geosciences/seawater/seawater-3.3.4.ebuild b/sci-geosciences/seawater/seawater-3.3.4.ebuild
new file mode 100644
index 000000000000..61d43cf99c41
--- /dev/null
+++ b/sci-geosciences/seawater/seawater-3.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="Python version of the SEAWATER 3.2 MATLAB toolkit for calculating the properties of sea water"
+HOMEPAGE="https://pypi.python.org/pypi/seawater/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # seems there are files missing
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/oct2py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}