summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/swmm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/swmm')
-rw-r--r--sci-geosciences/swmm/Manifest1
-rw-r--r--sci-geosciences/swmm/files/swmm-5.0.022-QA.patch14
-rw-r--r--sci-geosciences/swmm/metadata.xml8
-rw-r--r--sci-geosciences/swmm/swmm-5.0.022.ebuild53
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-geosciences/swmm/Manifest b/sci-geosciences/swmm/Manifest
new file mode 100644
index 000000000000..89e6c7a891b5
--- /dev/null
+++ b/sci-geosciences/swmm/Manifest
@@ -0,0 +1 @@
+DIST swmm50022_engine.zip 338011 SHA256 4dba36cbe5e39524c06b826e265ae8fdd2afb82b1c63bb5d9fd72214ed2d7409 SHA512 aa424d36c062656611bc6d6e4ced3108b6fd05806bf47ace30b44cc631860423073ad4fcafb523b2bf0ce7c73c5edc4386e5129009984d3d34f34e9260c69006 WHIRLPOOL feea6403a47ab88e95cc04b1d9b4f99e8fc26c2b5f1c51f69cf78f9ea71e70852bbfa71cea2466771c74ddf555cc5c92b7afa81ea1bc83baddb9cbf5a6a9f7fa
diff --git a/sci-geosciences/swmm/files/swmm-5.0.022-QA.patch b/sci-geosciences/swmm/files/swmm-5.0.022-QA.patch
new file mode 100644
index 000000000000..c84d50f5f6b3
--- /dev/null
+++ b/sci-geosciences/swmm/files/swmm-5.0.022-QA.patch
@@ -0,0 +1,14 @@
+--- Makefile
++++ Makefile
+@@ -7,9 +7,10 @@
+ rain.o rdii.o report.o routing.o runoff.o shape.o snow.o stats.o \
+ statsrpt.o subcatch.o table.o toposort.o transect.o treatmnt.o xsect.o
+
++LIBS += -lm
+
+ swmm5 : $(objs)
+- cc -o swmm5 -lm $(objs)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o swmm5 $(objs) $(LIBS)
+
+ swmm5.o : consts.h macros.h enums.h error.h datetime.h objects.h funcs.h text.h globals.h swmm5.h
+ climate.o : headers.h
diff --git a/sci-geosciences/swmm/metadata.xml b/sci-geosciences/swmm/metadata.xml
new file mode 100644
index 000000000000..e96e35b1a37c
--- /dev/null
+++ b/sci-geosciences/swmm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/sci-geosciences/swmm/swmm-5.0.022.ebuild b/sci-geosciences/swmm/swmm-5.0.022.ebuild
new file mode 100644
index 000000000000..7059bb8efbad
--- /dev/null
+++ b/sci-geosciences/swmm/swmm-5.0.022.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator toolchain-funcs
+
+MY_PV=$(delete_all_version_separators)
+MY_SRC="swmm${MY_PV}_engine.zip"
+DESCRIPTION="Storm Water Management Model - SWMM, hydrology, hydraulics, and water quality model"
+HOMEPAGE="http://www.epa.gov/ednnrmrl/models/swmm/index.htm"
+SRC_URI="http://www.epa.gov/nrmrl/wswrd/wq/models/swmm/${MY_SRC}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_unpack() {
+ unpack ${MY_SRC}
+ # Need to delete Readme.txt, because it is in makefiles.zip
+ rm Readme.txt || die
+ unpack ./makefiles.zip
+ unpack ./GNU_CON.zip
+ unpack ./source*.ZIP
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-QA.patch
+}
+
+src_compile(){
+ # 'sed' command has to accomodate DOS formatted file.
+ sed -i \
+ -e 's;^#define DLL;//#define DLL;' \
+ -e 's;^//#define CLE;#define CLE;' \
+ swmm5.c || die
+ emake
+}
+
+src_install(){
+ newbin swmm5 swmm
+ dodoc Roadmap.txt
+}