summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-25 17:46:55 +0000
committerSam James <sam@gentoo.org>2020-09-25 17:46:55 +0000
commit0b7a6ea689c896fa26dbc857f5e8c13628596a0d (patch)
treecb6bc59ae56879297234ad9f1553ee3a94951da6 /sci-geosciences
parentdev-python/iniconfig: Stabilize 1.0.0 arm64, #744268 (diff)
downloadgentoo-0b7a6ea689c896fa26dbc857f5e8c13628596a0d.tar.gz
gentoo-0b7a6ea689c896fa26dbc857f5e8c13628596a0d.tar.bz2
gentoo-0b7a6ea689c896fa26dbc857f5e8c13628596a0d.zip
sci-geosciences/gpsd: call python_setup uncondiitonally
python_setup is called by the distutils machinery when USE=python, but wasn't in the USE=-python case until now. We need this because we're using (e)scons to build. Closes: https://bugs.gentoo.org/734352 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.21.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.21.ebuild b/sci-geosciences/gpsd/gpsd-3.21.ebuild
index 12d81cded2b4..8083dc4252b3 100644
--- a/sci-geosciences/gpsd/gpsd-3.21.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.21.ebuild
@@ -100,7 +100,12 @@ src_prepare() {
default
- use python && distutils-r1_src_prepare
+ if use python ; then
+ distutils-r1_src_prepare
+ else
+ # We're using escons, bug #734352
+ python_setup
+ fi
}
python_prepare_all() {