summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-01-29 19:27:55 +0100
committerSam James <sam@gentoo.org>2023-02-08 04:11:05 +0000
commit1d5832ee940cb0b6635d29bf2e9be39d20ce696b (patch)
treef7530fbb913ceaa6874640003464376ff03f85d6 /sci-geosciences
parentdev-python/filebytes: update SRC_URI (diff)
downloadgentoo-1d5832ee940cb0b6635d29bf2e9be39d20ce696b.tar.gz
gentoo-1d5832ee940cb0b6635d29bf2e9be39d20ce696b.tar.bz2
gentoo-1d5832ee940cb0b6635d29bf2e9be39d20ce696b.zip
sci-geosciences/grass: fix variable assignment order
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/grass-8.2.0-r6.ebuild8
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-geosciences/grass/grass-8.2.0-r6.ebuild b/sci-geosciences/grass/grass-8.2.0-r6.ebuild
index 2439b5ce2439..89da9d5144ac 100644
--- a/sci-geosciences/grass/grass-8.2.0-r6.ebuild
+++ b/sci-geosciences/grass/grass-8.2.0-r6.ebuild
@@ -13,17 +13,21 @@ HOMEPAGE="https://grass.osgeo.org/"
LICENSE="GPL-2"
+if [[ ${PV} =~ "9999" ]]; then
+ SLOT="0/8.3"
+else
+ SLOT="0/$(ver_cut 1-2 ${PV})"
+fi
+
GVERSION=${SLOT#*/}
MY_PM="${PN}${GVERSION}"
MY_PM="${MY_PM/.}"
if [[ ${PV} =~ "9999" ]]; then
inherit git-r3
- SLOT="0/8.3"
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
else
MY_P="${P/_rc/RC}"
- SLOT="0/$(ver_cut 1-2 ${PV})"
SRC_URI="https://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="amd64 ~x86"
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index ed97dc748c64..9adfe1854258 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -13,17 +13,21 @@ HOMEPAGE="https://grass.osgeo.org/"
LICENSE="GPL-2"
+if [[ ${PV} =~ "9999" ]]; then
+ SLOT="0/8.3"
+else
+ SLOT="0/$(ver_cut 1-2 ${PV})"
+fi
+
GVERSION=${SLOT#*/}
MY_PM="${PN}${GVERSION}"
MY_PM="${MY_PM/.}"
if [[ ${PV} =~ "9999" ]]; then
inherit git-r3
- SLOT="0/8.3"
EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
else
MY_P="${P/_rc/RC}"
- SLOT="0/$(ver_cut 1-2 ${PV})"
SRC_URI="https://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~ppc ~x86"