summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-16 14:47:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-16 14:47:32 +0200
commit1ef37c47a0260323f090525092ecc4875244b893 (patch)
treebbee6e7c6996c811a092f24e0c23f69b95b3219e /sci-geosciences
parentdev-games/simgear: Fix inconsistent indentation in metadata.xml (diff)
downloadgentoo-1ef37c47a0260323f090525092ecc4875244b893.tar.gz
gentoo-1ef37c47a0260323f090525092ecc4875244b893.tar.bz2
gentoo-1ef37c47a0260323f090525092ecc4875244b893.zip
sci-geosciences/gpsbabel: Fix build with Qt-5.9
Reported-by: Markus <M4rkusXXL@web.de> Gentoo-bug: 629560 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9.patch105
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.5.4-r1.ebuild5
2 files changed, 108 insertions, 2 deletions
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9.patch
new file mode 100644
index 000000000000..36db615f9dec
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.5.4-qt-5.9.patch
@@ -0,0 +1,105 @@
+From 30a345577a644125502f6e4f8b58ea3077ec8dad Mon Sep 17 00:00:00 2001
+From: Robert Lipe <robertlipe@gpsbabel.org>
+Date: Mon, 4 Sep 2017 23:20:00 -0500
+Subject: [PATCH] Prefer QStringLiteral over implicit conversion from Latin1
+ for Q5 5.9. Based on work by Bernd Zeimetz.
+
+---
+ gpx.cc | 14 +++++++-------
+ magproto.cc | 6 +++---
+ unicsv.cc | 8 ++++----
+ 3 files changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/gpx.cc b/gpx.cc
+index 3b3b963c..36701e52 100644
+--- a/gpx.cc
++++ b/gpx.cc
+@@ -494,7 +494,7 @@ tag_cache_desc(const QXmlStreamAttributes& attr)
+ {
+ cache_descr_is_html = 0;
+ if (attr.hasAttribute("html")) {
+- if (attr.value("html").toString().compare("True") == 0) {
++ if (attr.value("html").toString() == QStringLiteral("True")) {
+ cache_descr_is_html = 1;
+ }
+ }
+@@ -509,16 +509,16 @@ tag_gs_cache(const QXmlStreamAttributes& attr)
+ gc_data->id = attr.value("id").toString().toInt();
+ }
+ if (attr.hasAttribute("available")) {
+- if (attr.value("available").toString().compare("True", Qt::CaseInsensitive) == 0) {
++ if (attr.value("available").toString().compare(QStringLiteral("True"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_available = status_true;
+- } else if (attr.value("available").toString().compare("False", Qt::CaseInsensitive) == 0) {
++ } else if (attr.value("available").toString().compare(QStringLiteral("False"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_available = status_false;
+ }
+ }
+ if (attr.hasAttribute("archived")) {
+- if (attr.value("archived").toString().compare("True", Qt::CaseInsensitive) == 0) {
++ if (attr.value("archived").toString().compare(QStringLiteral("True"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_archived = status_true;
+- } else if (attr.value("archived").toString().compare("False", Qt::CaseInsensitive) == 0) {
++ } else if (attr.value("archived").toString().compare(QStringLiteral("False"), Qt::CaseInsensitive) == 0) {
+ gc_data->is_archived = status_false;
+ }
+ }
+@@ -972,7 +972,7 @@ gpx_end(const QString& el)
+ * last date we saw in this log.
+ */
+ case tt_cache_log_type:
+- if ((cdatastr.compare("Found it") == 0) &&
++ if ((cdatastr.compare(QStringLiteral("Found it")) == 0) &&
+ (0 == wpt_tmp->gc_data->last_found.toTime_t())) {
+ wpt_tmp->AllocGCData()->last_found = gc_log_date;
+ }
+@@ -1423,7 +1423,7 @@ fprint_xml_chain(xml_tag* tag, const Waypoint* wpt)
+ fprint_xml_chain(tag->child, wpt);
+ }
+ if (wpt && wpt->gc_data->exported.isValid() &&
+- tag->tagname.compare("groundspeak:cache") == 0) {
++ tag->tagname.compare(QStringLiteral("groundspeak:cache")) == 0) {
+ writer->writeTextElement("time",
+ wpt->gc_data->exported.toPrettyString());
+ }
+diff --git a/magproto.cc b/magproto.cc
+index 7c82e9fb..0deb7f33 100644
+--- a/magproto.cc
++++ b/magproto.cc
+@@ -819,11 +819,11 @@ mag_rd_init_common(const QString& portname)
+ */
+ QString exten = QFileInfo(curfname).suffix();
+ if (exten.length() > 0) {
+- if (0 == exten.compare("upt", Qt::CaseInsensitive)) {
++ if (0 == exten.compare(QStringLiteral("upt"), Qt::CaseInsensitive)) {
+ extension_hint = WPTDATAMASK;
+- } else if (0 == exten.compare("log", Qt::CaseInsensitive)) {
++ } else if (0 == exten.compare(QStringLiteral("log"), Qt::CaseInsensitive)) {
+ extension_hint = TRKDATAMASK;
+- } else if (0 == exten.compare("rte", Qt::CaseInsensitive)) {
++ } else if (0 == exten.compare(QStringLiteral("rte"), Qt::CaseInsensitive)) {
+ extension_hint = RTEDATAMASK;
+ }
+ }
+diff --git a/unicsv.cc b/unicsv.cc
+index 4a7d78ed..6312e9d2 100644
+--- a/unicsv.cc
++++ b/unicsv.cc
+@@ -430,13 +430,13 @@ unicsv_parse_time(const QString& str, int* msec, time_t* date)
+ static status_type
+ unicsv_parse_status(const QString& str)
+ {
+- if (str.compare("true", Qt::CaseInsensitive) == 0 ||
+- str.compare("yes", Qt::CaseInsensitive) == 0 ||
++ if (str.compare(QStringLiteral("true"), Qt::CaseInsensitive) == 0 ||
++ str.compare(QStringLiteral("yes"), Qt::CaseInsensitive) == 0 ||
+ str == "1") {
+ return status_true;
+ }
+- if (str.compare("false", Qt::CaseInsensitive) == 0 ||
+- str.compare("no", Qt::CaseInsensitive) == 0 ||
++ if (str.compare(QStringLiteral("false"), Qt::CaseInsensitive) == 0 ||
++ str.compare(QStringLiteral("no"), Qt::CaseInsensitive) == 0 ||
+ str == "0") {
+ return status_false;
+ }
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.5.4-r1.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.5.4-r1.ebuild
index 5e68061b6b07..992aea9a44c9 100644
--- a/sci-geosciences/gpsbabel/gpsbabel-1.5.4-r1.ebuild
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.5.4-r1.ebuild
@@ -6,10 +6,10 @@ EAPI=6
inherit autotools eutils qmake-utils
DESCRIPTION="GPS waypoints, tracks and routes converter"
-HOMEPAGE="http://www.gpsbabel.org/ https://github.com/gpsbabel/gpsbabel"
+HOMEPAGE="https://www.gpsbabel.org/ https://github.com/gpsbabel/gpsbabel"
SRC_URI="
https://dev.gentoo.org/~asturm/${P}.tar.gz
- doc? ( http://www.gpsbabel.org/style3.css -> gpsbabel.org-style3.css )"
+ doc? ( https://www.gpsbabel.org/style3.css -> gpsbabel.org-style3.css )"
LICENSE="GPL-2"
SLOT="0"
@@ -50,6 +50,7 @@ PATCHES=(
"${FILESDIR}/${P}-use_system_shapelib.patch"
"${FILESDIR}/${P}-use_system_zlib.patch"
"${FILESDIR}/${P}-xmldoc.patch"
+ "${FILESDIR}/${P}-qt-5.9.patch"
)
RESTRICT="test" # bug 421699