summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-03-27 22:40:10 +1100
committerSam Jorna <wraeth@gentoo.org>2016-03-27 22:58:00 +1100
commit3c1f1e58b246fa7e7cdcad0214b558d465524da3 (patch)
tree71ba36770c987d21021ac68045316c53abae6efe /sci-geosciences
parentsci-geosciences/gpsd: bump to 3.16 (diff)
downloadgentoo-3c1f1e58b246fa7e7cdcad0214b558d465524da3.tar.gz
gentoo-3c1f1e58b246fa7e7cdcad0214b558d465524da3.tar.bz2
gentoo-3c1f1e58b246fa7e7cdcad0214b558d465524da3.zip
sci-geosciences/mapserver: bump to 7.0.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/mapserver/Manifest1
-rw-r--r--sci-geosciences/mapserver/mapserver-7.0.1.ebuild174
2 files changed, 175 insertions, 0 deletions
diff --git a/sci-geosciences/mapserver/Manifest b/sci-geosciences/mapserver/Manifest
index 735318aeeec3..918b376b47e2 100644
--- a/sci-geosciences/mapserver/Manifest
+++ b/sci-geosciences/mapserver/Manifest
@@ -1 +1,2 @@
DIST mapserver-7.0.0.tar.gz 2495028 SHA256 b306b8111e0718a577ce595640c2d3224f913745af732a1b75f6f5cb3dddce45 SHA512 1e4d15f6c42cdf0b00533e2aa26c1b65f84bdbb3a91538d6addde3aa0e8874deed4969146cf7045858bcab2880e4d7429965660c5985d175bd19ce018ae90652 WHIRLPOOL f18f0679b70da795d0585df2dbcc07fda0f8533c9ef7972280301446e5d521d9f24f0ff482d8e5497954e3b67436f2f9f2576516f6f088dc388046314817a46b
+DIST mapserver-7.0.1.tar.gz 2606929 SHA256 2c9567e59ae3ebd99bb645740485be6a25798b8b57f93ca3413a3e0369a1bd8f SHA512 10cf58920a3083280a748efa087f105ed2e29650d10b56b7d457c46fd7fc4670a021db1aa27186997aaa3ea1b6a5b2772f2ffc5d8de48130f5ebed654215f2df WHIRLPOOL 0ef70bd312aba706c19ebc8d324e9ac2bc72bb400cbdb539c20ca0ea383744f363425dbc2dc1b70f8e133b0e84409645505a880f2e5689345e8c7bd7c5e952d5
diff --git a/sci-geosciences/mapserver/mapserver-7.0.1.ebuild b/sci-geosciences/mapserver/mapserver-7.0.1.ebuild
new file mode 100644
index 000000000000..30abc851c6aa
--- /dev/null
+++ b/sci-geosciences/mapserver/mapserver-7.0.1.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="${PN}-${PV/_/-}"
+
+PHP_EXT_OPTIONAL_USE="php"
+PHP_EXT_NAME="php_mapscript"
+PHP_EXT_S="${WORKDIR}/${MY_P}/mapscript/php/"
+PHP_EXT_SKIP_PHPIZE="no"
+USE_PHP="php5-4 php5-5"
+
+PYTHON_COMPAT=( python2_7 )
+
+#USE_RUBY="ruby18 ruby19"
+#RUBY_OPTIONAL="yes"
+
+WEBAPP_MANUAL_SLOT=yes
+
+inherit eutils depend.apache webapp distutils-r1 flag-o-matic perl-module php-ext-source-r2 multilib cmake-utils # ruby-ng
+
+DESCRIPTION="Development environment for building spatially enabled webapps"
+HOMEPAGE="http://mapserver.org/"
+SRC_URI="http://download.osgeo.org/mapserver/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="bidi cairo gdal geos mysql opengl perl php postgis proj python threads tiff xml xslt" # ruby php tcl
+
+REQUIRED_USE="php? ( ^^ ( php_targets_php5-4 php_targets_php5-5 ) )
+ xslt? ( xml )"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/fcgi
+ >=media-libs/gd-2.0.12[truetype,jpeg,png,zlib]
+ media-libs/giflib
+ net-misc/curl
+ virtual/jpeg:=
+ virtual/libiconv
+ x11-libs/agg
+ bidi? ( dev-libs/fribidi
+ media-libs/harfbuzz )
+ cairo? ( x11-libs/cairo )
+ gdal? ( >=sci-libs/gdal-1.8.0 )
+ geos? ( sci-libs/geos )
+ mysql? ( virtual/mysql )
+ opengl? (
+ media-libs/ftgl
+ media-libs/mesa
+ )
+ perl? ( dev-lang/perl:= )
+ postgis? ( dev-db/postgis )
+ proj? ( sci-libs/proj net-misc/curl )
+ tiff? (
+ media-libs/tiff:=
+ sci-libs/libgeotiff
+ )
+ xml? ( dev-libs/libxml2:2 )
+ xslt? ( dev-libs/libxslt[crypt] )
+"
+DEPEND="${RDEPEND}
+ perl? ( >=dev-lang/swig-2.0 )
+ python? ( >=dev-lang/swig-2.0 )"
+
+need_apache2
+
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.0-sec-format.patch" # see https://github.com/mapserver/mapserver/pull/5248
+ "${FILESDIR}/${PN}-7.0.0-no-applicable-code.patch"
+)
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+ use perl && perl_set_version
+ #use ruby && ruby-ng_pkg_setup
+}
+
+src_unpack() {
+ # unpack A and then copy the php thingies into workdir/php-slot
+ php-ext-source-r2_src_unpack
+ # HACK: and then remove it and replace by symlink
+ for slot in $(php_get_slots); do
+ rm -rf "${WORKDIR}/${slot}" || die
+ ln -s "${PHP_EXT_S}" "${WORKDIR}/${slot}" || die
+ done
+}
+
+src_prepare() {
+ local glibdir="${EPREFIX}/usr/include/glib-2.0"
+ local usrglibdir="${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
+
+ sed -e "s:^include_directories(:&${glibdir})\ninclude_directories(:" \
+ -i "${S}/CMakeLists.txt" || die
+ sed -e "s:include_directories(:&${usrglibdir})\ninclude_directories(:" \
+ -i "${S}/CMakeLists.txt" || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCMAKE_SKIP_RPATH=ON"
+ "-DWITH_ORACLESPATIAL=OFF"
+ "-DWITH_SDE=OFF"
+ "-DWITH_APACHE_MODULE=ON"
+ "-DWITH_ICONV=ON"
+ "-DWITH_GD=ON"
+ "-DWITH_GIF=ON"
+ "-DWITH_CURL=ON"
+ "-DWITH_FCGI=ON"
+ "-DINSTALL_LIB_DIR=$(get_libdir)"
+ "-DWITH_PROJ=$(usex proj ON OFF)"
+ "-DWITH_WMS=$(usex proj ON OFF)"
+ "-DWITH_KML=$(usex xml ON OFF)"
+ "-DWITH_GEOS=$(usex geos ON OFF)"
+ "-DWITH_GDAL=$(usex gdal ON OFF)"
+ "-DWITH_OGR=$(usex gdal ON OFF)"
+ "-DWITH_POSTGIS=$(usex postgis ON OFF)"
+ "-DWITH_MYSQL=$(usex mysql ON OFF)"
+ "-DWITH_LIBXML2=$(usex xml ON OFF)"
+ "-DWITH_XMLMAPFILE=$(usex xslt ON OFF)"
+ "-DWITH_FRIBIDI=$(usex bidi ON OFF)"
+ "-DWITH_HARFBUZZ=$(usex bidi ON OFF)"
+ "-DWITH_CAIRO=$(usex cairo ON OFF)"
+ "-DWITH_PHP=$(usex php ON OFF)"
+ "-DWITH_PYTHON=$(usex python ON OFF)"
+ "-DWITH_PERL=$(usex perl ON OFF)"
+ )
+
+ if use gdal && use proj ; then
+ mycmakeargs+=( "-DWITH_WFS=ON"
+ "-DWITH_WCS=ON"
+ "-DWITH_CLIENT_WMS=ON"
+ "-DWITH_CLIENT_WFS=ON"
+ "-DWITH_SOS=$(usex xml ON OFF)"
+ )
+ else
+ mycmakeargs+=( "-DWITH_WFS=OFF"
+ "-DWITH_WCS=OFF"
+ "-DWITH_CLIENT_WMS=OFF"
+ "-DWITH_CLIENT_WFS=OFF"
+ "-DWITH_SOS=OFF"
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ webapp_src_preinst
+ exeinto "${MY_CGIBINDIR}"
+ doexe "${S}_build/mapserv"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}
+
+pkg_prerm() {
+ webapp_pkg_prerm
+}