summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-10 12:13:21 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-10 12:13:39 +0100
commit53e64a2a4336e0f77845909d551151b14f86bedc (patch)
treed30360e8635189494eccf9e745d40b82b6ffff77 /sci-geosciences
parentdev-python/click-plugins: update EAPI 7 -> 8, pep517, enable py3.11 (diff)
downloadgentoo-53e64a2a4336e0f77845909d551151b14f86bedc.tar.gz
gentoo-53e64a2a4336e0f77845909d551151b14f86bedc.tar.bz2
gentoo-53e64a2a4336e0f77845909d551151b14f86bedc.zip
sci-geosciences/pymap3d: new package, add 2.9.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/pymap3d/Manifest1
-rw-r--r--sci-geosciences/pymap3d/metadata.xml11
-rw-r--r--sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-geosciences/pymap3d/Manifest b/sci-geosciences/pymap3d/Manifest
new file mode 100644
index 000000000000..fe187fce8b30
--- /dev/null
+++ b/sci-geosciences/pymap3d/Manifest
@@ -0,0 +1 @@
+DIST pymap3d-2.9.1.tar.gz 47889 BLAKE2B 5f070a8155719215f6a2b7a8a2585fdf855b47ff610ea86511e4e270eecd3d1c866aadf125f2f2a847f059678fe10e75c61e7c6edeaca78f62dfac43beacaa54 SHA512 ea294d5d9f9ae2b949f281c64023cd2bf4b3667ad9c76e794ac242ae833d70ed45a5a422561aede1d734108c3accbf5fda2aaadb00d27885754a8244e4fc4cb3
diff --git a/sci-geosciences/pymap3d/metadata.xml b/sci-geosciences/pymap3d/metadata.xml
new file mode 100644
index 000000000000..83943bd9d184
--- /dev/null
+++ b/sci-geosciences/pymap3d/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">geospace-code/pymap3d</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild b/sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild
new file mode 100644
index 000000000000..d6a7520cbad7
--- /dev/null
+++ b/sci-geosciences/pymap3d/pymap3d-2.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python 3-D coordinate conversions"
+HOMEPAGE="https://github.com/geospace-code/pymap3d"
+SRC_URI="https://github.com/geospace-code/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="test? (
+ dev-python/xarray
+ dev-python/pyproj
+)"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm src/pymap3d/tests/test_eci.py || die
+ default
+}