summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2019-05-09 20:23:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-24 01:32:22 +0200
commit567699c1e23dc53dd85f75f25689af945419ef35 (patch)
treebc0df4466b5d204c70695773af4539c0845f16a2 /sci-geosciences
parentdev-qt/qtwebkit: Fix build against ICU-65 (diff)
downloadgentoo-567699c1e23dc53dd85f75f25689af945419ef35.tar.gz
gentoo-567699c1e23dc53dd85f75f25689af945419ef35.tar.bz2
gentoo-567699c1e23dc53dd85f75f25689af945419ef35.zip
sci-geosciences/qgis: Update dependencies, mycmakeargs and install
- Python 3 is required for building QGIS - media-gfx/exiv2 required for analysis/raster/qgsexiftools.cpp - dev-qt/qtxmlpatterns was never used and now not required - explicitly enable WITH_ANALYSIS and WITH_GUI - icons and desktop file are now installed by CMake - optimize Python installed in site-packages Closes: https://github.com/gentoo/gentoo/pull/11932 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index e7a74b82fac5..73aa5dd50222 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -27,6 +27,7 @@ IUSE="3d examples georeferencer grass hdf5 mapserver netcdf opencl oracle polar
REQUIRED_USE="${PYTHON_REQUIRED_USE} mapserver? ( python )"
BDEPEND="
+ ${PYTHON_DEPS}
>=dev-qt/linguist-tools-${QT_MIN_VER}:5
sys-devel/bison
sys-devel/flex
@@ -50,6 +51,7 @@ COMMON_DEPEND="
>=dev-qt/qtsql-${QT_MIN_VER}:5
>=dev-qt/qtwidgets-${QT_MIN_VER}:5
>=dev-qt/qtxml-${QT_MIN_VER}:5
+ media-gfx/exiv2:=
>=sci-libs/gdal-2.2.3:=[geos]
sci-libs/geos
sci-libs/libspatialindex:=
@@ -93,7 +95,6 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
>=dev-qt/qttest-${QT_MIN_VER}:5
- >=dev-qt/qtxmlpatterns-${QT_MIN_VER}:5
python? ( ${PYTHON_DEPS} )
"
RDEPEND="${COMMON_DEPEND}
@@ -128,7 +129,9 @@ src_configure() {
-DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt5.so
-DPEDANTIC=OFF
-DUSE_CCACHE=OFF
+ -DWITH_ANALYSIS=ON
-DWITH_APIDOC=OFF
+ -DWITH_GUI=ON
-DWITH_INTERNAL_MDAL=ON # not packaged, bug 684538
-DWITH_QSPATIALITE=ON
-DENABLE_TESTS=OFF
@@ -166,18 +169,6 @@ src_configure() {
src_install() {
cmake-utils_src_install
- newmenu linux/org.qgis.qgis.desktop.in org.qgis.qgis.desktop
-
- local size type
- for size in 16 22 24 32 48 64 96 128 256; do
- newicon -s ${size} linux/icons/${PN}-icon${size}x${size}.png ${PN}.png
- newicon -c mimetypes -s ${size} linux/icons/${PN}-mime-icon${size}x${size}.png ${PN}-mime.png
- for type in qgs qml qlr qpt; do
- newicon -c mimetypes -s ${size} linux/icons/${PN}-${type}${size}x${size}.png ${PN}-${type}.png
- done
- done
- newicon -s scalable images/icons/qgis_icon.svg qgis.svg
-
insinto /usr/share/mime/packages
doins debian/qgis.xml
@@ -188,6 +179,7 @@ src_install() {
fi
if use python; then
+ python_optimize
python_optimize "${ED}"/usr/share/qgis/python
fi