summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-07-28 13:12:42 -0400
committerRick Farina <zerochaos@gentoo.org>2020-07-28 14:12:03 -0400
commit7158269938d3357d60b205354369cbc6c405d00b (patch)
tree3b5723f001947cb7c5fbaad77424505896fdcd7f /sci-geosciences
parentsci-geosciences/gpsd: more die (diff)
downloadgentoo-7158269938d3357d60b205354369cbc6c405d00b.tar.gz
gentoo-7158269938d3357d60b205354369cbc6c405d00b.tar.bz2
gentoo-7158269938d3357d60b205354369cbc6c405d00b.zip
sci-geosciences/gpsd: fix systemd units
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.20.ebuild5
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.20.ebuild b/sci-geosciences/gpsd/gpsd-3.20.ebuild
index 14a770778674..5b207643d5d7 100644
--- a/sci-geosciences/gpsd/gpsd-3.20.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.20.ebuild
@@ -89,6 +89,10 @@ src_prepare() {
-e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
SConstruct || die
+ #Fix systemd binary paths
+ sed -i -e 's/local\///' 'systemd/gpsd.service'
+ sed -i -e 's/local\///' 'systemd/gpsdctl@.service.in'
+
default
use python && distutils-r1_src_prepare
@@ -124,6 +128,7 @@ src_configure() {
prefix="${EPREFIX}/usr"
libdir="\$prefix/$(get_libdir)"
udevdir="$(get_udevdir)"
+ rundir="/run"
chrpath=False
gpsd_user=gpsd
gpsd_group=uucp
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index cd96667f22ed..73c52f149eb1 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -89,6 +89,10 @@ src_prepare() {
-e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
SConstruct || die
+ #Fix systemd binary paths
+ sed -i -e 's/local\///' 'systemd/gpsd.service'
+ sed -i -e 's/local\///' 'systemd/gpsdctl@.service.in'
+
default
use python && distutils-r1_src_prepare
@@ -128,6 +132,7 @@ src_configure() {
prefix="${EPREFIX}/usr"
libdir="\$prefix/$(get_libdir)"
udevdir="$(get_udevdir)"
+ rundir="/run"
chrpath=False
gpsd_user=gpsd
gpsd_group=uucp