summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-12-29 23:29:58 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2016-12-30 19:00:27 +0100
commit7f6989edc1b8229abd448fef7e99bffb336db09d (patch)
treef5f4edc8904bcfbb01e92c174e59d024f0624b8d /sci-geosciences
parentsci-geosciences/opencpn-plugin-radar: added new plugin (diff)
downloadgentoo-7f6989edc1b8229abd448fef7e99bffb336db09d.tar.gz
gentoo-7f6989edc1b8229abd448fef7e99bffb336db09d.tar.bz2
gentoo-7f6989edc1b8229abd448fef7e99bffb336db09d.zip
sci-geosciences/opencpn-plugin-polar: added new plugin
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-polar/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-polar/metadata.xml15
-rw-r--r--sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-1.1007.ebuild38
-rw-r--r--sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-9999.ebuild38
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-polar/Manifest b/sci-geosciences/opencpn-plugin-polar/Manifest
new file mode 100644
index 000000000000..7b5c67338958
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-polar/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-polar-1.1007.tar.gz 263299 SHA256 0b0e11003d7b11fbf05047e13a08700b86ae74e5c3aa125b4bb61659c8a9af24 SHA512 9ef853a052692b7475851b8470d18c711bf2e9a8fd7dbc31919197fa6ae0225ce218bd4a13f39a999fa29282b209614e0fc37e429a39dc3c1dc28b018e6c3344 WHIRLPOOL 683447093278e47b1ed3df3e79a4657608daea50942425c114a04c02656a4f166554dfd6b024a4c626b14d3f7fb16a4812a98f113c44669106289a0ca78b6a04
diff --git a/sci-geosciences/opencpn-plugin-polar/metadata.xml b/sci-geosciences/opencpn-plugin-polar/metadata.xml
new file mode 100644
index 000000000000..3d00c813eab8
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-polar/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-geosciences@gentoo.org</email>
+ <name>Gentoo Geosciences Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ptulp/polar_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-1.1007.ebuild b/sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-1.1007.ebuild
new file mode 100644
index 000000000000..c0189e125168
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-1.1007.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="polar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/ptulp/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/ptulp/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Polar Diagram Plugin for OpenCPN"
+HOMEPAGE="https://github.com/ptulp/polar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-9999.ebuild b/sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-9999.ebuild
new file mode 100644
index 000000000000..c0189e125168
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-polar/opencpn-plugin-polar-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="polar_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/ptulp/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/ptulp/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Polar Diagram Plugin for OpenCPN"
+HOMEPAGE="https://github.com/ptulp/polar_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}